Úvod

Informační systém ISvoš je určen pro zpracování agendy vysokých a vyšších odborných škol

Jedná se o databázový systém s dvouvrstvou architekturou klient server.
Standardně tento systém pracuje s n+1 databázemi (n lokálních a jedna vzdálená), kde n je počet poboček školy. Lokální databáze je vždy umístěna na lokálním serveru ve škole (resp. pobočce školy) tak, aby k ní měly v rámci sítě LAN přístup všechny počítače, na kterých je provozován ISvoš Manažer. Vzdálená databáze běží v Internetu na serveru v doméně isvos.cz a je přístupná 24 hodin denně.
Škola bez poboček má tedy 2 databáze (jednu lokální ve škole, a jednu vzdálenou).

Školy s trvalým a kvalitním připojením do Internetu mohou využít i architekturu s jednou lokální databází, která zároveň slouží i jako vzdálená. V tomto případě musí škola sama zajistit provozování webového serveru s trvalým přístupem do Internetu, na kterém poběží internetová část systému ISvoš.

Jako databázový server lze použít obecně server podporující standard SQL. V praxi je však u všech zákazníků použit MySQL server verze 4.1.3 a nebo vyšší a to jak na platformě Windows tak i na platformě Linux. Na tomto serveru je i systém vyvíjen a testován.

Informační systém ISvoš je rozdělen do následujících částí:

ISvoš Manažer
Jedná se o 32 bitovou aplikaci pro operační systém Windows, která je určená pro studijní oddělení. Umožňuje evidenci a zpracování veškerých dat (informace o studentech, zaměstnancích a učitelích, přijímací řízení, výuka, zpracování studijních výsledků, platby a mnoho jiného). Kromě toho systém obsahuje podporu nejrůznějších tiskových výstupů (například obálky, složenky, vysvědčení a diplomy, potvrzení o studiu, klasifikační archy, osobní karty, různé statistické výstupy apod.). Aparát tiskových sestav je postaven tak, aby umožnil snadnou a rychlou úpravu stávajících a tvorbu nových tiskových sestav.
Přístup do ISvoš Manažera je chráněn uživatelským jménem a heslem (kryptováno MD5). Podporována je i autorizace proti LDAP serveru. ISvoš Manažer může být nainstalován v rámci LAN na libovolném množství počítačů.

Internetová webová část
Je umístěna na vzdáleném výkonném počítači s velmi rychlým připojením do sítě Internet. Tato část systému realizuje webové rozhraní pro uživatele (uchazeče, studenty, učitele atd.). Pomocí tohoto rozhraní si mohou například studenti kontrolovat své studijní výsledky, zapisovat se na zkušební termíny, vybírat si volitelné předměty, kontrolovat a případně upravovat své osobní údaje a podobně. Stejně tak učitelé mohou například vypisovat zkušební termíny, zapisovat známky atd. Součástí je i webová přihláška ke studiu. Uchazeči rovněž mohou sledovat výsledky přijímacího řízení atd. Kromě toho obsahuje tato část systému mohutnou a precizně propracovanou podporu elektronických nástěnek. Zprávy na tyto nástěnky, lze umísťovat i adresně, takže uživatel není obtěžován zprávami, které se ho netýkají.
Webové rozhranní neobsahuje obrázky (s výjimkou fotografií osob), nepoužívá cookies, ActiveX a nevyžaduje JavaScript ani jiné klientské skripty. Přístup do internetového rozhranní je chráněn jménem a heslem. Heslo je uloženo v databázi (zakryptováno MD5). Podporována je i autorizace proti LDAP serveru. Používá http autorizaci a zabezpečený (https) přenos.

Synchronizátor dat
Tato Win32 aplikace slouží pro sjednocení dat mezi lokální a vzdálenou databází. Synchronizace dat se spouští přímo z ISvoš Manažera.

Technická podpora - hotline
Jde o Windows aplikaci umožňující uživateli ISvoš Manažera interaktivně komunikovat s pracovníky technické podpory. Tento program je spustitelný z ISvoš Manažera.


Architektura systému

Systém ISvoš je navržen tak, aby umožnil uživatelům přístup do informačního systému i ze vzdálených počítačů, připojených do celosvětové sítě Internet. Tento přístup je realizován pomocí internetového webového rozhranní a uživateli stačí mít pouze běžný internetový prohlížeč.

Aby bylo možné zajistit přístup do systému i pro školy, které nemají kvalitní nebo trvalé připojení do Internetu byla zvolena architektura dvou databází (obr. 1). Jedna (lokální) databáze je lokálně umístěna v budově školy a umožňuje v rámci sítě LAN studijnímu oddělení a ostatním složkám školy plnohodnotnou práci se systémem pomocí ISvoš Manažera.
Kopie (vzdálená) databáze je umístěna na výkonném vzdáleném počítači s rychlým připojením do Internetu. Tento server je přístupný v doméně http://nazev_skoly.isvos.cz a umožňuje přístup k datům pomocí internetového prohlížeče.

Obě dvě databáze fungují samostatně a jejich data stačí občas synchronizovat. K synchronizaci dat slouží speciální program dodávaný spolu se systémem. Proces synchronizace je na obrázku 1 znázorněn oranžovou šipkou.

obr. 1: standardní architektura systému ISvoš

Druhá varianta (obr. 2) spojuje lokální a vzdálenou databázi do jedné, čímž odpadá proces synchronizace a dostupná data jsou neustále aktuální. Tato architektura ovšem vyžaduje dostatečně rychlé, trvalé a spolehlivé připojení školního serveru do Internetu a instalaci a správu webového serveru, což je zejména pro menší školy nemožné.
I tato architektura umožňuje připojení poboček školy. V tom případě musí být jedna databáze zvolena jako centrální a ostatní servery se synchronizují s touto databází (pobočky nejsou na obr. znázorněny).

obr. 2: architektura s jedním databázovým serverem

Všechny programy tvořící součást systému ISvoš (ISvoš Manažer, Synchronizátor a Hotline) jsou uloženy v databázi. V databázi jsou zkomprimovány, zašifrovány a podepsány.

Poskytovatel systému ISvoš (společnost Computer Aided Technologies) má přístup do vzdálené databáze. Nové verze programu jsou průbežne umísťovány do vzdálené databáze dokud je synchronizátor „stáhne" do lokální databáze. Tím je zajištena automatická aktualizace, která je pro uživatele transparentní. Vzdálená databáze je denně zálohována.


Technické požadavky

Informační systém ISvoš je koncipován tak, aby pro jeho provoz bylo možné použít běžně dostupné HW i SW vybavení.

Databázový server
· SW požadavky:
databázový server podporující standard SQL. Doporučený server MySQL verze 4.1.3 nebo vyšší.
operační systém závisí na typu databázového serveru (Windows, Linux ...)
· HW požadavky:
dle typu databázového serveru a operačního systému

Webový server (pouze při architektuře s jednou databází)
· SW požadavky:
funkční web server (Apache, IIS apod.)
podpora PHP skriptů (PHP verze 4.2.0 nebo vyšší). V případě autorizace proti LDAP serveru musí PHP podporovat LDAP funkce.
doporučujeme podporu šifrování přenosu dat pomocí SSL
operační systém závisí na použitém web serveru (Windows, Linux ...)
· HW požadavky:
dle typu operačního systému
trvalé a stabilní připojení do Internetu min. rychlostí 1Mb/s (závisí na předpokládaném vytížení serveru)

ISvoš Manažer
· SW požadavky:
operační systém MS Windows 2000 nebo MS Windows XP
SW balík MS Office 2000 nebo vyšší (pro práci s tiskovými sestavami vyžaduje MS Excel, pro tvorbu zpráv na elektronickou nástěnku je nutný MS Word a pro prohlížení zpráv MS Internet Explorer 5 nebo vyšší)
přístup do lokální databáze přes port 3306 (standardně)
· HW požadavky:
doporučená HW konfigurace odpovídá doporučené HW konfiguraci operačního systému MS Windows 2000, příp. MS Windows XP

Synchronizátor
· SW požadavky:
operační systém MS Windows 2000 nebo MS Windows XP
přístup do lokální databáze přes port 3306 (standardně)
· HW požadavky:
doporučená HW konfigurace odpovídá doporučené HW konfiguraci operačního systému MS Windows 2000, příp. MS Windows XP
připojení k Internetu min. rychlostí 56 kb/s (doporučeno 256 kb/s a vyšší)

Technická podpora - hotline
· SW požadavky:
operační systém MS Windows 2000 nebo MS Windows XP
přístup do Internetu přes port 80
· HW požadavky:
doporučená HW konfigurace odpovídá doporučené HW konfiguraci operačního systému MS Windows 2000, příp. MS Windows XP
připojení k Internetu min. rychlostí 56 kb/s

Webový klient
· SW požadavky:
internetový prohlížeč (doporučen MS IE 6.0, ale podporovány jsou i IE 5.0, IE 5.5, Opera 7, Netscape Navigator, FireFox apod.)
přístup do Internetu přes port 80
· HW požadavky:
připojení k Internetu alespoň vytáčeným připojením