Úvod

E-learning Informačního systému ISvoš

E-learning (electronic learning - elektronická výuka) je vzdělávací proces, využívající informační a komunikační technologie k tvorbě kurzů, k distribuci studijního obsahu, komunikaci mezi studenty a pedagogy a k řízení studia.

E-learning informačního systému ISvoš je přístupný přes webové rozhranní jednotlivých uživatelů a je plně integrován do stávajícího uživatelského rozhranní. To znamená, že přístup je chráněn přihlašovacím jménem a heslem a jednotliví uživatelé mají přístup pouze k funkcím a informacím, které jsou určeny pro ně.

Veškerá funkčnost (vytváření struktury kurzu, psaní jednotlivých kapitol, editování zkušebních testů, vyhodnocování testů a úkolů atd.) je zajištěna pouze prostředky internetového prohlížeče, čili pro práci s e-learningem není vyžadována instalace nějakého dalšího podpůrného programu nebo služby.

Pro plnohodnotnou práci s e-learningem je doporučeno používat internetový prohlížeč Internet Explorer verze 5.5 a vyšší nebo Mozila FireFox verze 1.0.4 a vyšší. V ostatních moderních internetových prohlížečích by měl být e-learning funkční, nicméně v těchto prohlížečích nebyla funkčnost e-learningu testována.
upozorneni Upozornění: Pro editaci a otevírání kurzů (rozhranní pro vyučující) je nutné mít v internetovém prohlížeči zapnutou podporu JavaScriptu! Pro studium kurzů (rozhranní pro studenty) není JavaScript nutný, ale doporučujeme podporu JavaScriptu zapnout. Výrazně si tím usnadníte práci s kurzem

Názvosloví
Vzhledem k neustálým změnám v názvosloví používaném ve školském zákonu jsou v následujícím textu používány následující pojmy:
· semestr (příp. období) - je polovina školního roku.
· studijní obor (nebo jen obor) - název typu studia na škole. U vysokých škol se nazývá "studijní program".
· zaměření studia (nebo jen zaměření) - je specializace v rámci studijního oboru. Obor se může dělit na několik zaměření. U vysokých škol se "studijní program" dělí na "obory".
· student - osoba studující na vysoké nebo vyšší odborné škole.
· hodnocení předmětu - umožňuje v předmětu udělovat hodnocení (známku, počet bodů nebo obojí) podle nastavených pravidel.
· vlastní hodnocení - je hodnocení předmětu, které vytvořil vyučující, který předmět učí. Toto hodnocení nemá přímý vliv na fungování systému, pouze umožňuje vyučujícím a studentům jednodušší orientaci při známkování.
· konečné hodnocení - je takové hodnocení předmětu, které určuje, zda student předmět úspěšně absolvoval.
· e-learningový kurz (nebo jen kurz) - je souhrn studijních matriálů, úkolů a zkušebních testů, které tvoří jeden celek. Jednotlivé kurzy se dají otevírat pro různé skupiny studentů.
· část kurzu - je součást e-lerningového kurzu. Může to být kapitola (studijní text), úkol nebo zkušební test.


Práce s kurzy

Práce s e-learningovými kurzy

Přístup k e-learningovému kurzu mají přes své webové rozhranní dvě skupiny uživatelů:

1. učitelé
Každý učitel má na svém webovém rozhranní záložku nazvanou "E-learning". Tato záložka je rozdělena na dvě podzáložky.

V pravé části je záložka "Vytváření kurzů". Na této záložce může učitel vytvářet nové kurzy a upravovat vytvořené kurzy. Podrobné informace o vytváření a editaci kurzů najdete v následující kapitole Vytváření a úpravy kurzů.

Vlevo je záložka nazvaná "Otevřené kurzy". Zde může vyučující otevírat vytvořené kurzy pro zvolenou skupinu studentů, které učí.
V otevřených kurzech může jednak provádět nastavení jednotlivých běhů kurzu (např. nastavení datumů přístupnosti kurzu a jeho částí apod.) a dále zde může hodnotit úkoly obsažené v kurzu, případně sledovat výsledky testů. Více informací se dozvíte v kapitole Otevření a provozování kurzu.

poznamka Poznámka: Při vytváření nebo v otevřených kurzech se občas můžete setkat s nápovědou, která vám pomůže pochopit význam některých nastavení. Nápověda je indikována otazníkem na tmavším pozadí. Po najetí kurzoru myši nad tento otazník se zobrazí nápověda v "bublině". Po kliknutí na otazník se nápověda zobrazí v dialogovém okně.

2. studenti
Na záložce "E-learning" na webovém rozhranní studentů je přístupný seznam všech kurzů, které byly pro studenta otevřeny. Kliknutím na kurz si může student spustit ten kurz, který chce studovat. Pro další informace pokračujte kapitolou Studium kurzu.


Vytváření a úpravy kurzů

Vytvářet e-learningové kurzy mohou pouze vyučující. Na svém webovém rozhranní na záložce "E-learning" je vpravo nahoře podzáložka s názvem "Vytváření kurzů". Na této podzáložce se nacházení ikony jednotlivých vytvořených kurzů. Kliknutím na příslušnou ikonu kurzu se otevře kurz v režimu editace, čímž je umožněno provádět úpravy v již vytvořených kurzech.
První ikona na záložce "Vytváření kurzů" má název "Vytvořit nový kurz". Kliknutím na tuto ikonu se vytvoří nový e-learningový kurz a tento kurz se rovnou otevře.

Editace kurzů

Okno pro editaci e-learningového kurzu je rozděleno do dvou částí:
· na levé straně je tzv. strom kurzu, který zobrazuje obsah kurzu. Celý e-learningový kurz se může skládat ze tří částí:
- kapitola - jedná se o studijní text, který popisuje a vysvětluje danou problematiku. kapitola, jako jediná část kurzu, může obsahovat další vnořenou úroveň, kterou můžou tvořit další kapitoly (podkapitoly), úkoly nebo testy.
- úkol - je cvičení, které student vypracovává dle instrukcí uvedených v úkolu. Úkol lze odevzdat ve formě textu napsaného přímo při odevzdávání úkolu, anebo ve formě souboru, který student připojí k odevzdávanému úkolu. Hodnocení úkolů provádí učitel v otevřeném kurzu.
- test - jedná se o automaticky vyhodnocovaný test, složený z určitého počtu testových otázek. Definice testových otázek je součástí tvorby e-learningového kurzu. Testy studenti vyplňují přímo na webu přes své rozhranní informačního systému. Výsledky testů může vyučující prohlížet a kontrolovat v otevřeném kurzu.
· na pravé straně se zobrazuje obsah jednotlivých částí kurzu. Obsah se liší podle typu vybrané části.

Poměr zobrazení levé a pravé části lze změnit najetím kurzoru myši na rozhranní mezi oběma částmi (kurzor myši se změní na vodorovnou dvojšipku) a stisknutím levého tlačítka myši a tažením upravíte velikost oken podle vlastních potřeb.

Popis a práce se stromem

Strom zobrazuje obsah e-learningového kurzu. Otevřené kurzy (jak u vyučujících tak u studentů) zobrazují strom téměř stejně, proto je důležité, aby strom (resp. členění kurzu) bylo přehledné a jednoduché na pochopení.

Pro práci se stromem se používají tlačítka nástrojových lišt umístěných nad vlastním stromem.

Rozbalování a sbalování částí stromu tlacitkarozbaleni

Pro větší přehlednost můžou být jednotlivé části (větve) stromu sbaleny. To zda některá kapitola obsahuje další části kurzu je ve stromu indikováno jednak ikonou kapitoly (kniha) a jednak ikonkou stromu (čtvereček se znaménkem plus nebo mínus).
Rozbalení příslušné větve stromu provedete kliknutím na ikonku čtverečku se znaménkem plus. Znaménko ve čtverečku se změní na mínus (indikuje rozbalenou větev) a ve stromu se zobrazí příslušné podkapitoly, případně úkoly a testy.
Obdobným způsobem provedete sbalení (skrytí) obsahu větve. Klikněte na ikonku čtverečku se znaménkem mínus - ikonka se změní na plus a obsah větve se skryje.

V případě, že potřebujete rychle sbalit nebo rozbalit celý strom, můžete použít tlačítka s odpovídajícími symboly na nástrojové liště nad stromem. Tlačítkem s plusem rozbalíte celý strom (včetně zanořených větví), tlačítkem s mínusem celý strom sbalíte, čili bude viditelná pouze 1. úroveň kapitol.

Vytváření obsahu kurzu - přidávání kapitol, úkolů a testů tlacitkapridani

Kořen stromu tvoří vlastní e-learningový kurz. Klinutím na tento kořen se v pravé části zobrazí informace o kurzu.
Kurz se může skládat z jednotlivých částí: kapitol, úkolů a testů. Přidávání jednotlivých částí se provádí pomocí tří tlačítek na nástrojové liště nad vlastním stromem.

Klinutím na příslušné tlačítko se vytvoří nová část jako větev (potomek, podúroveň) části, která je zrovna vybrána. To znamená, že pokud chceme vytvořit novou kapitolu, úkol nebo test v hlavní části stromu (1. úrovni), musí být před kliknutím na přidávací tlačítko vybrán kořen, čili název kurzu.

poznamka Poznámka: Potomky (části nižších úrovní) lze vytvářet pouze v kapitolách. Pokud ve stromu vyberete úkol nebo test, tlačítka pro přidávání budou neaktivní a nepůjde vytvořit nová část.

Po vytvoření nové části se tato část automaticky vybere a v pravé části se zobrazí její vlastnosti.

Mazání částí kurzu tlacitkomazani

K mazání jednotlivých částí kurzu slouží tlačítko s červeným křížkem na první liště. Po vybrání požadované části klikněte na toto tlačítko. Systém se ještě jednou zeptá, zda opravdu chcete tuto část kurzu smazat. Kliknutím na tlačítko OK se část odstraní, výběrem tlačítka Storno se vrátíte zpět, aniž by došlo k jakékoliv změně.

Část kurzu (resp. kapitola), která obsahuje potomky (podkapitoly, případně úkoly nebo testy) nelze smazat. Nejprve musíte postupně odstranit všechny potomky a teprve potom smazat nadřazenou kapitolu.

Kořen stromu (kurz) nelze odstranit.

Přesouvání části kurzu

Vytvořené části kurzu lze libovolně přesouvat ve struktuře stromu. Přesouvání je realizováno tažením myší:
nad přesouvanou částí stiskněte levé tlačítko myši a při stisknutém tlačítku posuňte ukazatelem myši na místo, kam chcete část přesunout. Při přesouvání se změní kurzor myši na kříž se šipkami a název přesouvané části se zobrazí šedou kurzívou. Při přesouvání části kurzu jsou zvýrazňovány dva stavy:
1. kurzor myši umístíte nad text názvu části - celý text se podbarví šedou barvou
pokud v tomto okamžiku pustíte levé tlačítko myši, umístí se přesouvaná část jako první potomek části, nad kterou jste tlačítko pustili. To znamená, že se umístí na začátek větve této kapitoly. Pokud kapitola žádné potomky (podkapitoly) nemá, vytvoří se nová větev. Potomky lze vytvářet pouze u kapitol a kořenu. Pokud přesouvanou část pustíte nad názvem úkolu nebo testu objeví se chybová hláška, že tato část nemůže obsahovat.

presundo

2. kurzor myši umístíte nad ikonu části (případně číslo kapitoly) - ikona i text se podtrhne šedou čárou
puštěním levého tlačítka myši se přesouvaná část umístí za část, nad kterou jste tlačítko pustili. To znamená, že se přesune na stejnou úroveň jako cílová část. To, zda cílová část obsahuje další části (potomky) na přesouvání nemá vliv.

presunza

Pokud je v kurzu zapnuto automatické číslování kapitol, dojde ihned po přesunu k přečíslování kapitol tak, aby číselná řada odpovídala struktuře dokumentu.

V případě, že chcete přesunout část do větve, která je sbalená (skrytá), můžete požadovanou větev rozbalit přejetím kurzoru myši přes ikonku s plusem před ikonou části kurzu. Tlačítko myši nepouštějte! Po přejetí se zobrazí obsah větve a tažením myší dál můžete vybrat cílové místo přesunutí.
Obdobným způsobem je možné celou větev skrýt. Přejetím kurzoru myši přes ikonku mínusu se větev sbalí.

poznamka Poznámka: Pokud přesouvaná část obsahuje další části (podkapitoly) bude přesunuta včetně celé struktury větve - se všemi podkapitolami, úkoly a testy.

upozorneni Upozornění: V případě, že při přesouvání vyjedete kurzorem myši mimo oblast stromu, celý proces přesouvání se ukončí aniž by k nějakému přesunu části došlo!

Platnost změn kurzu

Přidání nebo odstranění některé části kurzu se ihned projeví v otevřených (v tuto chvíli běžících) kurzech. U kurzů, které byly otevřeny, ale již skončili se přidání nebo odstranění některé části kurzu neprojeví. To znamená, že pokud byl kurz otevřen pro studenty a autor například přidá nový úkol, studenti tento úkol ihned uvidí.
Pokud student absolvoval některý kurz a tento kurz je již ukončen změna struktury kurzu se neprojeví - student uvidí kurz stejně jako v době, kdy tento kurz studoval.

Ostatní změny (přesunutí části kurzu, změna obsahu kapitoly nebo zadání úkolu apod.) se projeví ihned a to i zpětně ve všech kurzech. Kvůli tomu existují jistá omezení při úpravě úkolů a testů, aby nedocházelo ke změnám během odevzdávání úkolů nebo vypracovávání testů. Tato omezení jsou popsána v kapitolách jednotlivých částí.

tip Tip: Pokud chcete upravit část kurzu tak, aby se změny neprojevili zpětně u již ukončených kurzů, odstraňte příslušnou část a následně vytvořte část novou se stejným umístěním a případně i názvem. Obsah části potom můžete libovolně upravit. Pozor: nezapomeňte, že tyto úpravy se projeví v otevřených - běžících kurzech!

Obsah části kurzu

Obsah zvolené části kurzu je zobrazen v pravé části vedle stromu. Obsah různých částí má různý vzhled (obsahy jednotlivých částí budou popsány v následujících kapitolách), nicméně mají vždy stejné záhlaví.

V levé části záhlaví jsou dvě tlačítka, které umožňují zobrazit předchozí (<<) a následující (>>) část kurzu. Při procházení kurzu pomocí těchto tlačítek se vždy zobrazují všechny části tak, jak jdou za sebou bez ohledu na to, zda je příslušná větev ve stromu rozbalena či ne.
V prostřední části je uveden název aktuálně zobrazené části kurzu.
V pravé části je tlačítko s křížkem ( X ). Klinutím na toto tlačítko se ukončí práce s kurzem a zobrazí se seznam vytvořených kurzů.


Nastavení kurzu

Kliknutím na název kurzu ve stromu se v pravé části zobrazí informace týkající se nastavení celého kurzu. Stránka je rozdělena na dvě záložky:
· Vlastnosti - zde je možné nastavit některé vlastnosti týkající se celého kurzu
· Správce souborů - je souborový manažer, který umožňuje práci se soubory (např. obrázky, soubory s přílohami, doplňkové texty apod.), které nějak souvisí s kurzem.

Vlastnosti kurzu

U každého e-learningového kurzu lze nastavit základní vlastnosti kurzu. Mezi tyto vlastnosti patří:
· název kurzu - je pojmenování kurzu, které by mělo co nejpřesněji vystihovat obsah kurzu. Název vytvořeného kurzu se nabízí jako přednastavený název kurzu při jeho otevírání, ale jednotlivé otevřené kurzy lze přejmenovat (např. upřesnit název) - viz Nastavení kurzu v kapitole "Otevření a provozování kurzu".
· poznámka - je text (max. cca 250 znaků), který slouží pro uložení některých důležitých informací týkajících se vytvořeného kurzu. Tato poznámka je určena pouze pro autora kurzu, ostatní uživatelé (učitelé nebo studenti) tuto poznámku nevidí.
· automatické číslování kapitol - zatržením tohoto políčka se ve stromu bude před každou kapitolou zobrazovat pořadové číslo kapitoly včetně čísla nadřazené kapitoly. Čísla jednotlivých úrovní kapitol jsou odděleny tečkou. Automatické číslování kapitol udržuje číselnou řadu souvislou, takže nemůže dojít k výpadku některého čísla kapitoly. U jednodušších kurzů není číslování kapitol nutné.
· ikona - jedná se obrázek, který bude zobrazován u kurzu. Obrázek by měl co nejlépe vystihovat obsah kurzu, protože orientace v kurzech je daleko jednodušší podle obrázků než podle názvů.
Jako ikona kurzu lze použít některý z připravených obrázků. Kliknutím na požadovaný obrázek v seznamu "Ikona" -> "Možnosti" se tento obrázek zobrazí v náhledu v plné velikosti. Pokud s obrázkem souhlasíte, klikněte na tlačítko "Uložit" v pravém dolním rohu.
První obrázek v seznamu "Možnosti" zobrazuje současně nastavenou ikonu kurzu.
Vlastní ikona
Ke kurzu je možné přiřadit i vlastní obrázek. Tento obrázek musí být v souboru typu .GIF, .JPG nebo .PNG a měl by mít rozměry 48 x 48 bodů (pokud bude mít jiné rozměry, bude automaticky roztažen do velikosti 48 x 48 bodů). Maximální velikost souboru obrázku je omezena na 5 kB.
Cestu k souboru s obrázkem napište do editačního pole "Vlastní". Pro jednodušší nalezení obrázku klikněte na tlačítko "Procházet" a obrázek najděte na svém pevném disku. Klikněte na tlačítko "Načíst" a tím přiřadíte obrázek ke kurzu. Načtený obrázek se zobrazí v seznamu "Možnosti" jako druhá položka s označením "vlastní ikona".
· šablona - určuje vzhled jednotlivých částí kurzu. V levé části je seznam pro výběr z přednastavených možností vzhledu, v pravé části je ukázka vzhledu, jak bude dokument vypadat. Po výběru některé z možností se šablona zkopíruje do kurzu a v seznamu se zobrazuje jako položka "<vlastní šablona>". Takto vytvořenou šablonu může uživatel dále upravovat podle vlastních přání přímou editací souborů v adresáři "style" přes Správce souborů (viz dále). Tyto úpravy ovšem vyžadují znalosti HTML a kaskádových stylů (CSS). Popis úprav šablony přesahuje rámec tohoto manuálu.

Ve spodní části okna jsou dvě tlačítka:
- vlevo je tlačítko nazvané "Smazat kurz". Kliknutím na toto tlačítko se zobrazí dialogové okno pro potvrzení smazání celého kurzu. Pokud v dialogovém okně kliknete na tlačítko OK, dojde k nenávratnému smazání celého kurzu včetně všech jeho částí a připojených souborů. kliknutím na tlačítko Storno se vrátíte zpět k editaci vlastností kurzu.
- vpravo je umístěno tlačítko "Uložit". Provedete-li v nastavení kurzu nějaké změny. musíte klinout na toto tlačítko, aby se provedené změny uložili. Pokud na toto tlačítko nekliknete a přepnete se na jinou stránku (část kurzu, správce souborů apod.) budou nastavené změny ztraceny.

Správce souborů

Záložka "Správce souborů" umožňuje autorovi připojit ke kurzu další soubory, které budou použity v kurzu. Jedná se zejména o obrázky, grafy, zvukové a videonahrávky a další dokumenty v libovolných formátech.

Jednotlivé soubory lze organizovat do adresářové struktury stejně jako soubory na disku počítače. Po vytvoření nového kurzu a vybrání šablony kurzu na záložce "Vlastnosti" vznikne v přehledu souborů adresář nazvaný "style". V tomto adresáři jsou umístěny obrázky a další soubory pro nastavení vzhledu kapitol. Tyto soubory je možné nahradit nebo upravit podle potřeby autora, ale tato úprava vyžaduje znalost kaskádových stylů (CSS). Pokud tuto problematiku neovládáte, neprovádějte v adresáři "style" žádné změny.

Procházení adresářů a prohlížení souborů

O každém souboru a adresáři jsou v seznamu souborů zobrazeny některé informace. Kromě ikony a názvu souboru nebo adresáře je u souborů uvedena jeho velikost v násobcích bytů. U adresářů je uveden text <DIR> - z anglického directory. Dalším údajem uvedeným v seznamu je datum a čas vytvoření adresáře resp. uložení souboru.
V posledním sloupci je obrázek pro smazání příslušného souboru nebo adresáře. Po kliknutí na tento obrázek se zobrazí potvrzovací dialogové okno. Pokud opravdu chcete soubor nebo adresář odstranit, klikněte na tlačítko "OK" v dialogovém okně. V případě, že soubor smazat nechcete, klikněte na tlačítko "Storno".

upozorneni Upozornění: adresáře se mažou včetně celého obsahu. Před smazáním adresáře si ověřte, že chcete smazat i všechny soubory a podadresáře, které obsahuje!

Klinutím na název adresáře se přepnete na jeho obsah. Zobrazí se vám seznam všech souborů a případně i podadresářů, které obsahuje. V horním řádku nad seznamem souborů se zobrazí kompletní cesta do adresáře, jehož obsah máte zobrazený. První řádek seznamu souborů bude obsahovat položku, která má v názvu dvě tečky ( .. ). Klinutím na tuto položku se přepnete zpět do nadřazeného adresáře (o jednu úroveň víš). Základní adresář kurzu (nazývá se kořenový adresář) tuto položku neobsahuje, protože nemá žádný nadřazený adresář.

Klinutím na název souboru se v části "Vybraný soubor" zobrazí název souboru včetně cesty k souboru a pod ním u některých typů souborů může být zobrazen náhled. Náhled se zobrazuje např. u obrázků (typu .JPG, .GIF, .PNG), textových souborů (typu .TXT, .HTM, .CSS apod.) a vybraných video a audio souborů. v případě, že náhled nelze zobrazit, je v prostoru náhledu zobrazen text "Náhled není k dispozici".
Vpravo nahoře v části "Vybraný soubor" jsou dva obrázky. První z nich umožňuje vybraný soubor uložit na disk počítače. Po kliknutí na tento obrázek se zobrazí dialogové okno prohlížeče pro uložení souboru. Druhé tlačítko umožňuje smazat vybraný soubor, stejně jako kliknutí na obrázek v řádku souboru v seznamu.

Práce s adresáři

Pro vytvoření nového adresáře je nutné zadat jeho název. Do textového pole "Nový adresář" napište jméno adresáře, který chcete vytvořit a klikněte na tlačítko "Vytvořit". Název adresáře nesmí být shodný s již existujícím adresářem a nesmí obsahovat některé znaky (např. \, ?, * apod.). Pokud se podaří adresář vytvořit, přepnete se automaticky do tohoto adresáře a v seznamu se zobrazí jeho obsah (adresář bude prázdný - bude obsahovat pouze první položku pro návrat do nadřazeného adresáře.

Mazání adresářů se provádí klinutím na obrázek v příslušném řádku v pravé části seznamu - viz předchozí text.

Ukládání souborů

Pro nahrání nového souboru z disku lokálního počítače je nutné název souboru vyplnit do editačního pole "Přidat soubor". Pro zjednodušení zadávání jména souboru je možné kliknout na tlačítko "Procházet" a v otevřeném dialogovém okně najít potřebný soubor. Po vyplnění názvu klikněte na tlačítko "Nahrát" a soubor se nahraje do aktuálně zobrazeného adresáře v seznamu souborů. Pro nahrávané soubory platí dvě omezení:
1. Velikost souboru nesmí přesáhnout 2 MB. Toto omezení je dáno nastavením webového serveru na kterém běží informační systém. Maximální velikost ukládaného souboru lze v nastavení webového serveru změnit - tuto změnu může provést pouze administrátor (správce webového serveru).
2. Je zakázáno (resp. znemožněno) ukládat soubory obsahující webové skripty. jedná se o soubory .PHP, .PHP3, .PHP4, .PHP5, .PHTML, .INC apod.


Kapitoly

Vytváření a úpravy kapitol

Kapitoly jsou učební texty e-learningového kurzu. Pro vzhled a psaní učebních textů platí jistá pravidla, která ovšem přímo nesouvisí s problematikou vytváření e-learningových kurzů, proto se zde jimi nebudeme zabývat.

Každá kapitola obsahuje dvě záložky:
· Náhled - kde je zobrazen text kapitoly a kde je také možné tento text upravovat a
· Vlastnosti - zde se nastavují některé vlastnosti týkající se kapitoly.

Vlastnosti kapitoly

Každá kapitola má svůj název, který by měl vystihovat obsah kapitoly. Po vytvoření nové kapitoly je název nastaven na "Nová kapitola". Je vhodné ihned po vytvoření název změnit, abyste se vyhnuli zmatkům s názvy kapitol. Název kapitoly se zobrazuje ve stromu a v záhlaví obsahu kapitoly.
Ke každé kapitole si může autor napsat svou poznámku. Tato poznámka se studentům ani učitelům, kteří zajišťují výuku v kurzu, nezobrazuje.

Podmínka
U každé části kurzu lze definovat podmínku, kterou musí student splnit, aby měl přístup k této části. Splnění podmínky představuje:
- u kapitol - první otevření kapitoly. To zda student text kapitoly opravdu přečetl nebo ji jen otevřel a hned se přepnul na jinou část systém bohužel nemůže poznat.
- u úkolů - odevzdání úkolu a následné hodnocení vyučujícího klasifikačním stupněm nebo příslušným počtem bodů, představující vyhovující úkol. U nevyhovujících hodnocení může mít student možnost odevzdat opravený úkol znovu.
- u testů - odevzdání testu a jeho vyhodnocení jako úspěšný test. Testy jsou vyhodnocovány automaticky, proto je nutné u testu nastavit příslušnou hranici počtu bodů, při které je test považován za úspěšný. V případě neúspěšného testu může mít student možnost test opakovat.

Po provedených změnách ve vlastnostech kapitoly je nutné kliknout na tlačítko "Uložit", aby se změny uložily do databáze.

Náhled kapitoly

Záložka "Náhled" zobrazuje obsah kapitoly. Ve spodní části je pro informaci uvedeno kdy byla kapitoly vytvořena a kdy byla naposledy upravována.
Obsah kapitoly je možné vytisknout na tiskárně (zobrazí se standardní okno internetového prohlížeče pro tisk) anebo upravit.

upozorneni Upozornění: Jakékoliv změny v textu kapitoly se projeví ihned ve všech otevřených i ukončených kurzech.

Úpravy kapitoly

Po kliknutí na odkaz "Upravit" v pravém dolním rohu náhledu kapitoly se otevře nové okno prohlížeče s webovým editorem.

Práce s webovým editorem e-learningových kurzů je velice podobná práci s jakýmkoliv jiným vyšším textovým editorem. V horní části okna jsou nástrojové lišty, jejichž funkcí lze využívat při psaní textu kapitoly. Většinu okna zabírá prostor pro psaný text. Text je přímo vizuálně upravován do podoby, jak bude zobrazen čtenářům.

Nástrojová lišta "Soubor" listasoubor
Tato lišta obsahuje nástroje pro komplexní práci s textem:
· Uložit - uloží změny v textu do e-learningového kurzu. Při editování textu doporučujeme text průběžně ukládat! Uložený text se ihned projeví v náhledu kapitoly.
· Tisk - vytiskne text nebo označenou část textu na tiskárně. Po kliknutí se zobrazí standardní dialogové okno internetového prohlížeče pro tisk.
· Náhled - otevře nové okno prohlížeče a v něm zobrazí editovaný text tak, jak ho uvidí ostatní uživatelé (např. pokud text obsahuje tabulku bez rámečku, je při editaci zobrazen šedé čárkované orámování tabulky, ale v náhledu je tabulka zobrazena bez orámování)
· Najít - zobrazí dialogové okno pro vyhledání textového řetězce v editovaném textu.
· Nahradit - zobrazí dialogové okno pro vyhledání a nahrazení textového řetězce jiným řetězcem v editovaném textu.

Nástrojová lišta "Úpravy" listaupravy
Na této liště najdete funkce pro práci se schránkou a vrácení případně opakování poslední změny:
· Vyjmout - uloží označený text do schránky a z editovaného textu ho odstraní
· Kopírovat - uloží označený text do schránky (v editovaném textu zůstane)
· Vložit - umístí na pozici textového kurzoru obsah schránky. Pokud je ve schránce formátovaný text, vloží ho včetně formátu.
· Vložit neformátovaný text - vloží obsah schránky jako pouhý text - odstraní veškeré formátování textu.
· Zpět - vrátí poslední provedenou úpravu do stavu před touto změnou
· Znovu - opak funkce Zpět. Provede požadovanou akci znovu.
Funkce Zpět a Znovu lze použít i opakovaně.

Nástrojová lišta "Vložit" listavlozit
Funkce na této liště umožňují do textu vložit další objekty:
· Vložit odkaz - otevře dialogové okno pro vložení odkazu na soubor, internetovou nebo e-mailovou adresu. Toto tlačítko je aktivní pouze pokud je vybrán nějaký text. Tento text potom bude tvořit odkaz.
· Zrušit odkaz - převede vybraný (označený) odkaz zpět na normální text.
· Záložka (kotva) - umožňuje do textu vložit pojmenovanou záložku, na kterou je možné se odkazovat v rámci editovaného textu. Odkaz na záložku vytvoříte funkcí "Vložit odkaz", kde v dialogovém okně vyberete ze seznamu vytvořených záložek příslušnou položku. Záložka se vytvoří na pozici textového kurzoru.
· Obrázek - otevře dialogové okno pro vložení obrázku do textu. Obrázek může být součástí kurzu jako soubor, nebo se může odkazovat na soubor umístěný na Internetu. Kromě adresy umožňuje dialogové okno nastavit vzhled (zarovnání, okraj apod.) obrázku. Nový obrázek se vloží na pozici textového kurzoru.
· Video - otevře dialogové okno pro vložení video nebo audio záznamu. V dialogovém okně je nutné vybrat typ video (audio) záznamu a následně příslušný soubor, který může být buď součástí kurzu nebo na Internetu. Nastavení dalších vlastností závisí na vybraném typu. nový objekt se vloží na pozici textového kurzoru.
· Znak (symbol) - otevře dialogové okno s mapou znaků, které nelze zadat z klávesnice. Jedná se o různé matematické znaky, písmena řecké abecedy, znaky měn apod. Znak se vloží na pozici textového kurzoru.
· Vodorovný oddělovač - otevře dialogové okno pro nastavení vlastností vodorovné čáry, která opticky rozdělí napsaný text. Čára se vkládá na pozici textového kurzoru - vložení vodorovné čáry způsobí ukončení odstavce, vložení čáry a pokračování textu jako dalšího odstavce.
· Nová hladina - vytvoří "plovoucí okno", do kterého je možné napsat text, případně i vložit další objekt. Hladiny se většinou používají v kombinaci s absolutním pozicováním, které zajišťuje, že daná hladina bude vždy zobrazena tam, kde ji umístíte. Jednotlivých hladin lze v dokumentu vytvořit víc a jednotlivé hladiny se mohou i překrývat.
· Přesunout dopředu - pokud je v dokumentu více hladin, které se nesprávně překrývají, lze touto funkcí posunout vybranou hladinu o "úroveň" víš - dopředu. Tlačítko je aktivní pouze pokud je vybrána absolutně pozicovaná hladina.
· Přesunout dozadu - pokud je v dokumentu více hladin, které se nesprávně překrývají, lze touto funkcí posunout vybranou hladinu o "úroveň" níž - dozadu. Tlačítko je aktivní pouze pokud je vybrána absolutně pozicovaná hladina.
· Absolutní pozice - zapne/vypne u zvolené hladiny absolutní pozicování vůči začátku dokumentu. Absolutní pozicování způsobí, že hladina bude vždy zobrazena na místě, na které ji umístíte. Absolutní pozicování může vést k problémům při zmenšení okna prohlížeče tím, že normální text přeteče na pozici hladiny a obsah této hladiny text překryje. Tlačítko je aktivní pouze pokud je vybrána hladina.
· Datum - vloží na pozici textového kurzoru aktuální datum, které je nastaveno na vašem počítači. Datum je ve formátu textu, takže jde zpětně upravovat.
· Čas - vloží na pozici textového kurzoru aktuální čas, který je nastaven na vašem počítači. Čas je ve formátu textu, takže jde zpětně upravovat.

Nástrojová lišta "Formát 1" listaformat1
Tato lišta umožňuje měnit formát textu:
· Upravit CSS styl - otevře dialogové okno, ve kterém je možné nastavit vlastnosti vybraného objektu nebo vybraného textu. V dialogu lze nastavovat vzhled písma, pozadí (barva nebo obrázek) vybraného objektu, barvu šířku a styl rámečku kolem objektu a vzhled číslovaného nebo odrážkového seznamu.
· Zrušit formátování - odstraní veškeré formátování u vybraného objektu nebo textu.
· Styl (formát odstavce) - výběrem položky ze seznamu je možné jednoduše nastavit vzhled odstavce. Předdefinovány jsou normální odstavec a šest úrovní nadpisů. Styl se aplikuje na odstavec, ve kterém je umístěný textový kurzor.
· Font písma - výběrem některé položky z rozbalovacího seznamu se u označeného textu nastaví vybraný font písma.
· Velikost písma - výběrem některé položky z rozbalovacího seznamu se u označeného textu nastaví zvolená velikost textu. Údaje v závorce odpovídají velikostem písma používaných v textových editorech.
· Tučné písmo - u označeného textu přede písmo na tučné (nebo zpět na normální). Pokud není žádný text označen bude od této pozice textového kurzoru psán text tučně (případně se psaní tučným písmem ukončí).
· Kurzíva - nakloněné písmo. U označeného textu přede písmo na kurzívu (nebo zpět na normální). Pokud není žádný text označen bude od této pozice textového kurzoru psán text kurzívou (případně se psaní kurzívou ukončí).
· Podtržení - podtrhne označený text (nebo zruší podtržení). Pokud není žádný text označen bude od této pozice textového kurzoru text podtržený (případně se podtržení ukončí).
· Přeškrtnutí - přeškrtne označený text (nebo zruší přeškrtnutí). Pokud není žádný text označen bude od této pozice textového kurzoru text přeškrtnutý (případně se přeškrtnutí ukončí).

Nástrojová lišta "Formát 2" listaformat2
Pomocí nástrojů této lišty je možné měnit formát textu a odstavců:
· Dolní index - označený textu přede na dolní index (nebo zpět na normální). Pokud není žádný text označen bude od této pozice textového kurzoru psán text jako dolní index (případně se psaní dolním indexem ukončí).
· Horní index - označený textu přede na horní index (nebo zpět na normální). Pokud není žádný text označen bude od této pozice textového kurzoru psán text jako horní index (případně se psaní horním indexem ukončí).
· Barva textu - nastaví barvu označeného textu na stejnou barvu, jaká je zobrazena na tlačítku. Pokud nebyl žádný text vybrán, bude následující text za kurzorem psán nastavenou barvou. Kliknutím na šipku v pravé části tlačítka se zobrazí malá paleta barev, ze které je možné rychle vybrat novou barvu textu. Pokud je požadována barva, která v paletě není, klikněte na tlačítko "Další barvy" pod paletou. Otevře dialogové okno pro výběr barvy a zvolená barva se nastaví u textu.

· Barva pozadí - nastaví barvu pozadí označeného textu na stejnou barvu, jaká je zobrazena na tlačítku. Pokud nebyl žádný text vybrán, bude nastavena barva pozadí následujícího textu za kurzorem. Kliknutím na šipku v pravé části tlačítka se zobrazí malá paleta barev, ze které je možné rychle vybrat novou barvu pozadí. Pokud je požadována barva, která v paletě není, klikněte na tlačítko "Další barvy" pod paletou. Otevře dialogové okno pro výběr barvy a zvolená barva se nastaví u pozadí textu.
· Zarovnání vlevo - nastaví zarovnání k levému okraji u odstavce, ve kterém je textový kurzor, nebo u všech odstavců, jejichž alespoň část je označená
· Zarovnání na střed - nastaví zarovnání na střed (vycentrování řádků textu) u odstavce, ve kterém je textový kurzor, nebo u všech odstavců, jejichž alespoň část je označená
· Zarovnání vpravo - nastaví zarovnání k pravému okraji u odstavce, ve kterém je textový kurzor, nebo u všech odstavců, jejichž alespoň část je označená
· Zarovnání do bloku - roztáhne řádky tak, aby byly zarovnány po obou okrajích. Nastavení se provede u odstavce, ve kterém je textový kurzor, nebo u všech odstavců, jejichž alespoň část je označená
· Číslování - pokud není žádný text označený, převede odstavec, ve kterém je textový kurzor, na první položku číslovaného seznamu. Pokud je označena alespoň část dvou nebo více odstavců, převede jednotlivé odstavce na položky číslovaného seznamu.
· Odrážky - pokud není žádný text označený, převede odstavec, ve kterém je textový kurzor, na první položku odrážkového seznamu. Pokud je označena alespoň část dvou nebo více odstavců, převede jednotlivé odstavce na položky odrážkového seznamu.
· Snížit odsazení - posune levý okraj odstavce doleva. Aplikuje se na odstavec, ve kterém je umístěný textový kurzor, nebo na všechny odstavce, jejichž alespoň část je označená. Tato funkce je přístupná pouze pokud předtím bylo u odstavce použito Zvýšení odsazení.
· Zvýšit odsazení - posune levý okraj odstavce vpravo. Aplikuje se na odstavec, ve kterém je umístěný textový kurzor, nebo na všechny odstavce, jejichž alespoň část je označená. Zvýšení odsazení lze použít opakovaně.

Nástrojová lišta "Tabulka" listatabulka
Na této liště najdete nástroje pro práci s tabulkami. Kromě prvního tlačítka (Vytvořit novou tabulku) jsou všechny ostatní tlačítka přístupná pouze pokud je textový kurzor umístěn v buňce tabulky.
· Vložit novou tabulku / vlastnosti tabulky - otevře dialogové okno pro nastavení vlastností tabulky. U nové tabulky je nutné nastavit počet řádků a sloupců. Dále je zde možné nastavit šířku a barvu rámu tabulky, rozměry tabulky, barvu pozadí a další.
· Vlastnosti řádku - otevře dialogové okno, ve kterém můžete nastavit vlastnosti celého řádku. Jedná se např. o barvu pozadí, výšku, zarovnání textu atd.
· Vlastnosti buňky - otevře dialogové okno pro nastavení vlastností buňky (resp. buněk) tabulky. Lze nastavit např. zarovnání textu v buňce, výška, šířka, barva rámečku a pozadí buňky apod.
· Vložit nový řádek před - vytvoří nový řádek nad řádkem, v němž je umístěný textový kurzor.
· Vložit nový řádek za - vytvoří nový řádek pod řádkem, v němž je umístěný textový kurzor.
· Smazat řádek - odstraní řádek ve kterém je umístěný textový kurzor.
· Vložit nový sloupec před - vytvoří v tabulce nový sloupec umístěný před sloupcem, ve kterém je textový kurzor.
· Vložit nový sloupec za - vytvoří v tabulce nový sloupec umístěný za sloupcem, ve kterém je textový kurzor.
· Smazat sloupec - odstraní celý sloupec ve kterém je umístěný textový kurzor
· Rozdělit buňky - rozdělí sloučenou buňku na původní počet buněk (podle jednotlivých řádků a sloupců). Tato funkce je dostupná pouze v případě, že textový kurzor je umístěn v buňce, která byla předtím sloučena z více buněk.
· Sloučit buňky - zobrazí dialogové okno, ve kterém je potřeba zadat kolik buněk v řádku a ve sloupci chcete sloučit do jediné buňky. Počet řádků a sloupců se vždy počítá od buňky, ve které je umístěný textový kurzor.

Některé další funkce jsou přístupné z lokální nabídky (kontextového menu), které se zobrazí po kliknutí pravým tlačítkem nad libovolnou buňkou tabulky:

· Vyjmout řádek - zkopíruje celý řádek, ve kterém je umístěný textový kurzor, do schránky a zobrazený řádek smaže.
· Kopírovat řádek - zkopíruje celý řádek, ve kterém je umístěný textový kurzor, do schránky.
· Vložit řádek před - vloží řádek uložený ve schránce nad řádek, ve kterém je umístěný textový kurzor.
· Vložit řádek za - vloží řádek uložený ve schránce pod řádek, ve kterém je umístěný textový kurzor.
· Smazat tabulku - odstraní celou tabulku z dokumentu.

Nástrojová lišta "E-learning" listaelearning
Nástroje z této lišty umožňují vytvořit v textu dokumentu oddíly, které zpřehledňují učební text. Tyto oddíly jsou graficky zvýrazněné a mohou obsahovat obrázek (ikonu) identifikující obsah oddílu. Vzhled jednotlivých oddílů závisí na zvolené šabloně. Informace o výběru šablony najdete v kapitole Nastavení kurzu - Vlastnosti kurzu.
Oddíl lze vytvořit z označeného textu, přičemž formátování i jednotlivé odstavce zůstanou zachovány. Pokud není žádný text označen, vytvoří se oddíl z odstavce, ve kterém je umístěný textový kurzor.
Jednotlivé oddíly mohou být:
· Čas ke studiu - umožňuje uvést předpokládanou potřebnou dobu k prostudování kapitoly
· Výklad látky - informace o probírané problematice
· Důležité - zvýrazňuje důležité informace, které by si měl student zapamatovat
· Upozornění - upozorňuje na zajímavé problémy, definice apod.
· Souhrn - shrnutí probrané látky, souhrnné informace o problematice
· Poznámka - méně důležité informace, okrajové záležitosti, doplňující informace ...
· Rozšiřující text - další rozšiřující (nepovinné) informace pro zájemce o danou problematiku (např. další literatura apod.)
· Příklad - ukázkový příklad na dané téma
· Úloha, cvičení - cvičný příklad nebo úkol, který by si student měl zkusit sám vyřešit
· Otázka - "řečnická" otázka na studenty kurzu. tato otázky ba měla vést k zamyšlení studenta nad danou problematikou
· Klíč (řešení) - odpověď na položenou otázku, případně výsledné řešení úlohy nebo cvičného příkladu
· Zrušit formátování oddílu - zruší oddíl ve kterém je umístěn textový kurzor a text převede na obyčejný text. Formátování textu zůstane zachováno.

Ukončení editoru
Práci s editorem ukončíte zavřením okna editoru, např. kliknutím na tlačítko s křížkem vpravo nahoře. Pokud jste v dokumentu provedli nějaké změny a doposud je neuložili, upozorní vás editor na provedené změny a nabídne, zda chcete změny ignorovat a okno zavřít (v tom případě klikněte na tlačítko OK) anebo se vrátit zpět do editoru a změny uložit (potom klikněte na tlačítko Storno, uložte dokument a znovu zavřete okno editoru).


Úkoly

Vytváření a úpravy úkolů

Úkoly jsou části e-learningového kurzu, ve kterých musí student vypracovat zadaný úkol a odevzdat ho buď ve formě textu, který napíše jako vypracování úkolu, nebo ve formě souboru, který připojí k danému úkolu. Vyhodnocení a oznámkování úkolů provádí vždy vyučující (vedoucí kurzu).

Pro vytváření úkolů jsou k dispozici dvě záložky:
· Zadání - kde je zobrazen text zadání úkolu a kde je také možné tento text upravovat a
· Vlastnosti - zde se nastavují některé vlastnosti týkající se úkolu.

Vlastnosti úkolu

Každý úkol musí mít zadaný název. Při otevření kurzu pro studenty se automaticky vytvoří vlastní hodnocení se stejným názvem jako název úkolu. Proto doporučujeme název úkolu volit tak, aby mezi vlastními hodnoceními bylo hodnocení úkolu snadno rozpoznatelné.
Poznámka na záložce "Vlastnosti" slouží pro napsání doplňujících informací a poznámek k zadání úkolu. Tato poznámka slouží pouze pro autora - studenti ani učitelé v kurzu tuto poznámku neuvidí.

Podmínka
U každé části kurzu lze definovat podmínku, kterou musí student splnit, aby měl přístup k této části. Splnění podmínky představuje:
- u kapitol - první otevření kapitoly. To zda student text kapitoly opravdu přečetl nebo ji jen otevřel a hned se přepnul na jinou část systém bohužel nemůže poznat.
- u úkolů - odevzdání úkolu a následné hodnocení vyučujícího klasifikačním stupněm nebo příslušným počtem bodů, představující vyhovující úkol. U nevyhovujících hodnocení může mít student možnost odevzdat opravený úkol znovu.
- u testů - odevzdání testu a jeho vyhodnocení jako úspěšný test. Testy jsou vyhodnocovány automaticky, proto je nutné u testu nastavit příslušnou hranici počtu bodů, při které je test považován za úspěšný. V případě neúspěšného testu může mít student možnost test opakovat.

Hodnocení
Úkoly hodnotí vyučující, proto je nutné zvolit jakým způsobem bude hodnocení probíhat. Úkol může být hodnocen:
- klasifikační stupnicí - v tom případě zatrhněte první zaškrtávací políčko v oddílu "Hodnocení" a z rozbalovacího seznamu vyberte požadovanou klasifikační stupnici. Student má úkol splněný, pokud mu vyučující udělí úspěšnou známku.
- počtem bodů - pokud chcete úkol hodnotit pouze počtem bodů, zaškrtněte druhé políčko. Aby bylo možné stanovit, zda student úkol splnil, je nutné u bodového hodnocení zadat minimální počet bodů pro splnění úkolu. Pokud vyučující studentovi udělí minimální nebo vyšší počet bodů, má student úkol splněný.
- klasifikační stupnicí s počtem bodů (kombinace obou předchozích) - zaškrtnete-li obě políčka, bude možné u hodnocení zadat jak známku z příslušné stupnice, tak i po počet získaných bodů. Splnění úkolu se v tomto případě řídí podle klasifikační stupnice (zadáním úspěšné známky). Počet bodů je pouze doplňková informace a nemá na hodnocení vliv, proto není potřeba zadávat minimální počet bodů - editační pole bude nepřístupné.
U každého úkolu je možné zvolit, kolikrát může student odevzdat opravené vypracování úkolu. Pokud zadáte počet opravných hodnocení nula (0), nebude mít student možnost v případě nesplnění úkolu znovu odevzdat vypracování. Pokud všechna vypracování odevzdaná studentem jsou hodnocena jako nevyhovující a student vyčerpal všechny opravné hodnocení, nemůže mu vyučující změnit hodnocení a tím pádem by neměl mít možnost pokračovat dále ve studiu kurzu.

Po provedených změnách ve vlastnostech úkolu je nutné kliknout na tlačítko "Uložit" vpravo dole, aby se změny uložily do databáze.

Zadání úkolu

Záložka "Zadání" zobrazuje náhled zadání úkolu. Ve spodní části je pro informaci uvedeno kdy byl úkol vytvořen a kdy bylo naposledy zadání upraveno.
Zadání úkolu je možné vytisknout na tiskárně (zobrazí se standardní okno internetového prohlížeče pro tisk) anebo upravit.

Po kliknutí na odkaz "Upravit" se otevře nové okno internetového prohlížeče a v tomto okně se zobrazí webový editor. Práce s editorem je popsána v kapitole Vytváření a úpravy kapitol v části Úpravy kapitoly. V zadání úkolu není potřeba text dělit do zvýrazněných oddílů, proto při editaci zadání nejsou v editoru k dispozici funkce nástrojové lišty E-learning.

poznamka Poznámka: Součástí zadání úkolu by měly být informace o tom, jakým způsobem má být úkol odevzdán (text napsaný v kurzu nebo soubor), rozsah práce apod.

tip Tip: Pokud se pro vypracování úkolu předpokládá více souborů, je nutné aby součástí zadání bylo doporučení, aby studenti všechny soubory zkomprimovali (sbalili) do jednoho souboru nějakým komprimačním nástrojem - např.: ZIP, RAR apod. Odkaz na komprimační program může být součástí zadání, přičemž samotný program může být buď součástí kurzu nebo na nějakém serveru v Internetu.

Při tvorbě zadání úkolů mějte na mysli, že maximální velikost odevzdávaného souboru může být 2 MB. Proto nedoporučujeme vytvářet úkoly, jejichž vypracováním by měl být např. soubor s videem nebo větší obrázky ve vysoké kvalitě, u nichž může dojít k překročení max. velikosti odevzdávaného souboru.

Omezení editace úkolu

Jakékoliv změny v úkolu se ihned projeví ve všech otevřených kurzech - proto by ke změnám mělo docházet výjimečně. Aby se předešlo nechtěným nebo i záměrným změnám "pravidel během hry", může se stát, že v případě, že některý ze studentů úkol vypracoval a odevzdal, bude editace úkolu nepřístupná. Toto se projeví zobrazením hlášky

Toto omezení se týká jak nastavení vlastností úkolu tak i změny zadání. Změny budou povoleny až po ukončení odevzdávání úkolů v běžícím kurzu.

tip Tip: Pokud chcete upravit úkol kurzu tak, aby se změny neprojevili zpětně u již ukončených kurzů, odstraňte příslušný úkol a následně vytvořte úkol nový se stejným umístěním a případně i názvem. Obsah (zadání a vlastnosti) potom můžete libovolně upravit. Pozor: nezapomeňte, že tyto úpravy se projeví v otevřených - běžících kurzech!


Testy

Vytváření a úpravy testů

Testy jsou části e-learningového kurzu, ve kterých student postupně odpovídá na jednotlivé otázky. Testy jsou vyhodnocovány automaticky ihned po odevzdání. Výsledek testu student vidí ihned po jeho odevzdání.

Pro vytváření testů jsou k dispozici dvě záložky:
· Vlastnosti - zde se nastavují některé vlastnosti týkající se testu a
· Otázky - kde je zobrazen seznam jednotlivých otázek obsažených v testu.

Vlastnosti testu

Každý test musí mít zadaný název. Při otevření kurzu pro studenty se automaticky vytvoří vlastní hodnocení se stejným názvem jako název testu. Proto doporučujeme název testu volit tak, aby mezi vlastními hodnoceními bylo hodnocení testu snadno rozpoznatelné.
Poznámka slouží pro napsání doplňujících informací a poznámek k testu. Tato poznámka slouží pouze pro autora - studenti ani učitelé v kurzu tuto poznámku neuvidí.

Podmínka
U každé části kurzu lze definovat podmínku, kterou musí student splnit, aby měl přístup k této části. Splnění podmínky představuje:
- u kapitol - první otevření kapitoly. To zda student text kapitoly opravdu přečetl nebo ji jen otevřel a hned se přepnul na jinou část systém bohužel nemůže poznat.
- u úkolů - odevzdání úkolu a následné hodnocení vyučujícího klasifikačním stupněm nebo příslušným počtem bodů, představující vyhovující úkol. U nevyhovujících hodnocení může mít student možnost odevzdat opravený úkol znovu.
- u testů - odevzdání testu a jeho vyhodnocení jako úspěšný test. Testy jsou vyhodnocovány automaticky, proto je nutné u testu nastavit příslušnou hranici počtu bodů, při které je test považován za úspěšný. V případě neúspěšného testu může mít student možnost test opakovat.

Nastavení
Vzhledem k tomu, že student nevypracovává test pod dohledem učitele, musí být doba na zpracování omezená. Čas na zpracování testu se uvádí v minutách - pokud je na test potřeba více času jak jedna hodina, je nutné čas přepočítat na minuty, např. 1,5 hodiny = 90 minut.
Zadání testu je generováno automaticky ze zadaných otázek. U testu lze nastavit z kolika otázek bude test tvořen (hodnota v závorce udává počet vytvořených otázek v testu) a zda se mají otázky vybírat postupně tak jak jsou uvedeny na záložce "Otázky" nebo náhodně.
Poslední hodnota udává, kolikrát může student test absolvovat. Minimální hodnota je 1x - v tom případě student nemá možnost opravného testu.

Hodnocení
Testy jsou vyhodnocovány automaticky, proto je možné pouze bodové hodnocení. Pokud by z nějakého důvodu vyučující trval na hodnocení známkami, musí si vytvořit vlastní hodnocení a po odevzdání testů vždy bodové hodnocení převést na příslušnou známku a tuto známku studentovi zapsat do vlastního hodnocení.
Pokud je zatrženo políčko "výsledek testu je součástí hodnocení", bude při otevření kurzu automaticky vytvořeno vlastní hodnocení s názvem testu a výsledek tohoto testu se bude zobrazovat v hodnocení studenta. Aby bylo možné test vyhodnotit a stanovit, zda byl úspěšný nebo ne, musí být zadán minimální hranice počtu bodů. Studenti s tímto a vyšším počtem bodů mají test splněný a mohou pokračovat v kurzu. V opačném případě mohou test absolvovat znovu, dokud nevyčerpají zadaný počet spuštění testu.
V případě, že políčko "výsledek testu je součástí hodnocení" není zatrženo, jedná se cvičný test - výsledky takového testu se nezobrazují v hodnocení studenta a nemají vliv na pokračování ve studiu kurzu. Proto není potřeba zadávat minimální počet bodů - tato položka bude nepřístupná.

U každého testu je potřeba nastavit počet bodů získaných za správnou, chybnou a nezodpovězenou otázku. Tyto údaje student vidí ještě před spuštěním testu. Kladné číslo udává počet získaných bodů, záporné číslo udává počet ztracených bodů.
Jednotlivé otázky se mohou skládat z několika dílčích částí - viz dále v kapitole Vytváření a úprava otázek. Za správnou je považována odpověď, ve které jsou správně označeny a doplněny všechny dílčí části otázky, za chybnou odpověď je považována odpověď, ve které je vyplněna alespoň jedna dílčí část a alespoň jedna z dílčích odpovědí je špatná, a za nezodpovězenou je považována odpověď, ve které nebyla vyplněna ani jedna dílčí část otázky.

Po provedených změnách ve vlastnostech kapitoly je nutné kliknout na tlačítko "Uložit", aby se změny uložily do databáze.

Otázky testu

Seznam otázek

Na záložce "Otázky" je v levé části zobrazen seznam otázek připojených k vybranému testu. V záhlaví seznamu jsou na nástrojové liště umístěny tlačítka pro práci s otázkami:

Nová otázka tlacitkonovaotazka
Po kliknutí na toto tlačítko se v testu vytvoří nová prázdná otázka. Jednotlivé vlastnosti nové otázky je možné nastavit v pravé části záložky - viz dále.

Přidat otázky z jiného testu tlacitkopridatotazky (sdílení otázek)
Otázky lze mezi jednotlivými testy sdílet - tzn. že otázky vytvořené v jiném testu je možné znovu použít v tomto testu. U sdílené otázky je v seznamu otázek uvedeno na konci řádku s názvem otázky znaménko plus (+).
Pokud nejsou k dispozici žádné otázky, které by bylo možné do tohoto testu přidat (buď v jiných testech žádné otázky nejsou nebo jsou již všechny v tomto testu použity), zobrazí se v pravé části text vysvětlující proč není možné otázky přidávat. Jestliže existují nějaké otázky, které je možné přidat do tohoto testu, zobrazí se v pravé části seznam těchto otázek.

Označte v tomto seznamu ty otázky, které chcete přidat do testu kliknutím na zatrhávací pole před jménem otázky. Pokud chcete přidat všechny nabízené otázky (označit vše), klikněte na zatrhávací políčko v záhlaví seznamu. Pro přidání označených otázek klikněte na tlačítko nad seznamem otázek. Sdílené otázky se objeví v seznamu otázek vpravo a budou označeny znaménkem plus (+) na konci řádku.

Smazat označené otázky tlacitkosmazatotazku
Tato funkce umožňuje smazat otázky, které nechcete mít v testu. Před smazáním je nutné označit ty otázky, které chcete odstranit. Označení provedete kliknutím na zatrhávací pole před názvem v seznamu otázek. Označit a smazat lze více otázek naráz. Tlačítko pro smazání není aktivní pokud není označena alespoň jedna otázka.
Smazání otázky se projeví v otevřených (běžících) kurzech, čili tato otázka se nebude studentům, kteří spustí test, již nabízet. U ukončených kurzů zůstane otázka zachována. Pokud ji některý ze studentů v testu měl, uvidí ji nadále.

poznamka Poznámka: Pokud si nejste jisti, že otázku nebudete někdy v budoucnu chtít použít, nemusíte ji mazat. U každé otázky se dá nastavit, zda ji chcete v testu použít - viz dále v textu.

tip Tip: Pokud chcete otázku přesunout do jiného testu, nasdílejte ji (přidejte ji do jiného testu) a následně v původním testu otázku smažte. U sdílených otázek se maže pouze sdílení - tzn. že v ostatních testech zůstane zachována.

Posunout otázku nahoru/dolů tlacitkoposunoutotazku
Pro případ, že otázky v testu mají být vybírány postupně, je možné upravovat pořadí otázek v seznamu. Vybranou otázku (otázku vybere kliknutím na název otázky) můžete posunout nahoru, před předchozí otázku, nebo dolů - za následující otázku. Pořadí sdílených otázek jednoho testu nemá vliv na pořadí těchto otázek v jiném testu.

Vlastnosti otázek

V pravé části záložky "Otázky" jsou zobrazeny informace o vybrané otázce. Otázku vyberete kliknutím na její název v seznamu otázek - název vybrané otázky je zvýrazněn (zobrazen tučně).
U každé otázky je možné nastavit její název. Název otázky se nikde nezobrazuje a slouží pouze pro orientaci autora v seznamu otázek. Název otázky by měl být výstižný, ale ne moc dlouhý.
Dále má autor možnost ke každé otázce připojit poznámku. Tato poznámka se opět nikde nezobrazuje a slouží pouze pro potřeby autora. Pokud uvažujete o sdílení jednotlivých otázek mezi více testy, je možné do poznámky napsat např. název původního testu, ve kterém byla otázky vytvořena. Usnadní vám to později orientaci v seznamu otázek při jejich sdílení - viz odstavec Přidat otázky z jiného testu.

Povolit otázku v testech
Pokud toto políčko není zatrženo, je otázka součástí testu, ale v testu se nebude nabízet. V seznamu otázek jsou nepovolené otázky zobrazeny jinou (šedou) barvou textu. Pokud je otázka sdílená ve více testech, týká se její povolení resp. nepovolení všech testů. To znamená, že pokud otázku povolíte v jednom testu, bude povolena ve všech testech, kde je sdílená - tudíž nelze nastavit, aby v jednom testu byla otázka povolená a v jiném testu byla tatáž otázka nepovolená.
U otázek, které se mají nabízet při vypracovávání testu musí být toto políčko zatrženo.

Znění otázky
Znění otázky zobrazuje náhled otázky tak, jak ji uvidí student při vypracovávání testu.
Pod náhledem jsou k dispozici dva odkazy:
· "Vyzkoušet" - umožňuje vyzkoušení funkčnosti otázky. V náhledu je standardně zobrazena správná odpověď, ale je možné tuto odpověď změnit a poté vyzkoušet, zda byla odpověď vyhodnocena jako chybná. Stejné zobrazení odpovědi uvidí student i vyučující v otevřeném kurzu, pokud si zobrazí obsah odevzdaného (vyhodnoceného) testu.
· "Upravit" - kliknutím na tento odkaz se otevře nové okno prohlížeče s webovým editorem, ve kterém je možné upravit znění otázky. Více informací najdete v následující kapitole Vytváření a úprava otázek.

upozorneni Upozornění: Pokud je otázka sdílená ve více testech, změna zadání této otázky jakémkoliv testu se projeví i v ostatních testech!

Vytváření a úprava otázek
Každá otázka použitá v e-learningovém testu v sobě zahrnuje i možnosti odpovědi. Odpovědi můžou být různých typů (radiobutton, checkbox nebo text) a v jedné otázce lze použít i více typů odpovědí.
upozorneni Upozornění: Při vytváření, resp. úpravě otázek je nutné doplnit i správné řešení!

Editor otázek je velmi podobný editoru obsahu kapitol, který byl popsán v oddíle Vytváření a úpravy kapitol -> Úpravy kapitoly.
Při vytváření a úpravě otázky nejsou v editoru funkce z nástrojové lišty E-learning. Místo ní jsou k dispozici nástroje pro vytváření možných odpovědí:

Nástrojová lišta "Test" listatest
Na této liště jsou k dispozici tři nástroje:
· Vložit radiobutton - skupina těchto prvků má tu vlastnost, že je vždy možné vybrat pouze jednu jedinou možnost odpovědi. Označením jiné možnosti se automaticky zruší označení předchozí označené možnosti. Název radiobutton (v překladu rádiové tlačítko) vychází z označení tlačítek na starých rádiích, kdy při volbě vlnového rozsahu bylo možné mít stisknuto pouze jediné tlačítko. Stisknutím jiného tlačítka se stisknuté tlačítko vypnulo.
Tímto nástrojem je možné vytvářet odpovědi, kdy z nabízených možností je vždy jen jediná správná.
Vytvoření možnosti odpovědi: Pokud při výběru této funkce byla označena část textu, vloží se před tento text výběrový terčík a celý označený text se stane součástí možnosti odpovědi - pro označení možnosti je nutné kliknout na terčík nebo tento text. Text, který je součástí možnosti odpovědi je uzavřen v šedém čárkovaném rámečku a v případě potřeby ho lze dále upravovat. Rámeček se zobrazuje pouze při editaci - při vypracovávání a prohlížení otázky se orámování nezobrazuje.
Pokud žádný text označený nebyl, vloží se samotný výběrový terčík na místo textového kurzoru. Kolem terčíku se vytvoří šedý čárkovaný rámeček, do něhož lze napsat text, který bude součástí možnosti odpovědi. Doplnění textu není nutné - v tom případě bude pro označení možnosti odpovědi nutné kliknout přímo na terčík.

menuradiobutton

Nastavení správné možnosti: pokud chcete vybranou možnost nastavit jako správnou (označit ji) klikněte na označovací terčík pravým tlačítkem a ze zobrazené nabídky vyberte "Změnit stav". Pokud se pokusíte nastavit více možností jako správné, předchozí nastavená možnost se vždy odznačí. Pamatujte, že u tohoto typu odpovědi musí být vždy jedna možnost nastavena jako správná.

· Vložit checkbox (zatrhávací pole) - tento prvek rozlišuje dva stavy: zatrženo a nezatrženo, nezávisle na ostatních prvcích v odpovědi.
Skupinou těchto prvků lze vytvářet odpovědi, kdy z nabízených možností není buď žádná správná, jedna nebo i více správných.
Vytvoření možnosti odpovědi: Pokud při výběru této funkce byla označena část textu, vloží se před tento text zatrhávací políčko a celý označený text se stane součástí možnosti odpovědi - pro zatržení resp. odtržení možnosti je nutné kliknout na zatrhávací políčko nebo tento text. Text, který je součástí možnosti odpovědi je uzavřen v šedém čárkovaném rámečku a v případě potřeby ho lze dále upravovat. Rámeček se zobrazuje pouze při editaci - při vypracovávání a prohlížení otázky se orámování nezobrazuje.
Pokud žádný text označený nebyl, vloží se samotné zatrhávací políčko na místo textového kurzoru. Kolem políčka se vytvoří šedý čárkovaný rámeček, do něhož lze napsat text, který bude součástí možnosti odpovědi. Doplnění textu není nutné - v tom případě bude pro zatržení nebo odtržení možnosti odpovědi nutné kliknout přímo na políčko.

menucheckbox

Nastavení správné možnosti: pokud chcete u vybrané možnosti nastavit nebo zrušit zatržení, klikněte na zatrhávací políčko pravým tlačítkem a ze zobrazené nabídky vyberte "Změnit stav". Pokud bylo políčko zatrženo, zatržení se zruší a naopak. Tímto způsobem nastavte správný stav u všech možností odpovědi.
· Vložit textové pole - výběrem této funkce se zobrazí dialogové okno pro nastavení vlastností textového pole.
U textového pole lze nastavit hodnota, což je v podstatě správná odpověď, šířka textového pole (zadaná hodnota přibližně odpovídá počtu znaků, které jsou v textovém poli zobrazené) a typ. Typy mohou být následující:
- normální text - jako správná odpověď bude uznán text, který odpovídá zadanému textu v poli "Hodnota" (bez ohledu na velikost písmen).
- rozlišovat malá/velká písmena - jako správná odpověď bude uznán pouze text, který přesně odpovídá zadanému textu v poli "Hodnota" (student musí zadat správně i velká a malá písmena).
- číselná hodnota - odpověď tvoří číslo. Všechny odpovědi budou upraveny na jednotný formát (převedení desetinné tečky na čárku, odstranění všech mezer, odstranění nul na konci desetinné části apod.) a potom budou porovnány s textem v poli "Hodnota".
Vytvoření odpovědi: V případě, že při výběru této funkce byl označen nějaký text, nabídne se tento text v poli "Hodnota" jako správná odpověď a po kliknutí na tlačítko "Vložit" se na místo označeného textu vloží textové pole s nastavenou správnou odpovědí.
Pokud žádný text vybrán nebyl, vloží se textové pole na místo textového kurzoru v otázce.

tip Tip: Jak již bylo zmíněno na začátku, lze jednotlivé typy odpovědí v jedné otázce kombinovat. Aby takováto otázka byla hodnocená jako správně zodpovězená, je nutné správně vyplnit (označit) všechny možnosti otázky.

Omezení editace testu

Jakékoliv změny ve vlastnostech testu se ihned projeví ve všech otevřených kurzech - proto by ke změnám mělo docházet výjimečně. Aby se předešlo nechtěným nebo i záměrným změnám "pravidel během hry", může se stát, že v případě, že některý ze studentů test vypracoval a odevzdal, bude editace vlastností testu nepřístupná. Toto se projeví zobrazením hlášky

Toto omezení se netýká nastavení otázek. Systém jednotlivých otázek je řešen samostatně - smazané otázky se nenabízí v nově spuštěných testech, ale v odevzdaných testech se zobrazují i nadále. Při práci s otázkami v testu u kurzu, který je otevřen, mějte na paměti, že počet povolených otázek nesmí být menší než počet otázek použitých v testu!


Otevření a provozování kurzu

Každý vyučující má na svém webovém rozhranní záložku "E-learning". První podzáložka s názvem "Otevřené kurzy" obsahuje seznam všech otevřených kurzů v daném semestru. Semestr lze změnit výběrem jiné položky z rozbalovacího seznamu vpravo nahoře a následným kliknutím na tlačítko "Změnit". V seznamu semestrů jsou uvedeny pouze semestry, v nichž učitel vedl (provozoval) nějaký kurz + aktuální semestr. Název aktuálního semestru je psán černou barvou textu, starší semestry jsou zobrazeny šedou barvou textu.

Otevření kurzu

Otevření e-learningového kurzu může provést pouze jeho autor, tzn. učitel, který kurz vytvořil. Autor může kurz otevřít pro libovolnou skupinu studentů, kterou učí (studenty v předmětu, seminární skupině nebo v tématu). Kurzy lze otvírat pouze v aktuálním (probíhajícím) semestru.

Pokud vyučující vybere v seznamu semestrů probíhající semestr, bude jako první ikona na ploše záložky nazvaná "Otevřít nový kurz". Pokud vyučující nemá vytvořen žádný vlastní e-learningový kurz nebo pokud nemá v daném semestru žádnou výuku, bude tato první ikona pro otevření kurzu šedá a nepřístupná. V informačním textu pod názvem bude napsáno vysvětlení, proč není možné žádný kurz otevřít.

Kliknutím na ikonu "Otevřít nový kurz" se zobrazí okno, ve kterém je nutné specifikovat který e-learningový kurz chcete otevřít pro kterou skupinu studentů. Z rozbalovacího seznamu kurzů vyberte požadovaný e-learningový kurz. Při změně kurzu se změní obrázek v levé části na ikonu kurzu.

V druhém rozbalovacím seznamu je potřeba vybrat skupinu studentů. Nabízeny jsou všechny předměty, seminární skupiny a témata, ve kterých je učitel zapsán.

Kliknutím na tlačítko "<< Zpět" se vrátíte zpět na seznam otevřených kurzů, aniž by se nový kurz otevřel.
Pokud máte správně nastaveny obě položky, klikněte na tlačítko "Pokračovat >>". Tím dojde k otevření nového kurzu a zobrazí se obsah kurzu.

poznamka Poznámka: Nový kurz nejde otevřít pro skupinu studentů, pro které (nebo část z nich) je již tento kurz otevřen. Jinými slovy: pokud otevřete kurz pro jednu seminární skupinu z nějakého předmětu a později chcete ten samý kurz otevřít pro celý předmět, systém to nedovolí, protože někteří studenti by měli tento kurz otevřený dvakrát - jednou pro seminární skupina a podruhé pro předmět.

Provozování kurzů

Každý otevřený kurz (v konkrétním semestru) má vytvořenou ikonku na záložce "E-learning" -> "Otevřené kurzy".

U každého otevřeného kurzu je zobrazen obrázek (ikona) kurzu, kterou mu přidělil autor. Dále je zde uveden název kurzu - standardně je nastaven stejně jako název vytvořeného kurzu (od autora), ale tento název může vyučující změnit. Pod názvem kurzu může být uveden krátký popis, který opět zadává vyučující. Na posledních dvou řádcích je uvedeno od kdy do kdy a pro kterou skupinu studentů je tento kurz otevřen.

upozorneni Upozornění: Kurz může provozovat kterýkoliv z učitelů, který je zapsaný ve skupině (předmětu, sem. skupině), pro kterou je kurz otevřen. To znamená, že pokud je ve skupině vyučujících více, měli by se domluvit, který z nich kurz povede.

Kliknutím na ikonu se zobrazí obsah kurzu.

Obsah e-learningového kurzu se skládá ze dvou částí:
· na levé straně je tzv. strom kurzu, který zobrazuje obsah kurzu. Celý e-learningový kurz se může skládat ze tří částí:
- kapitola - jedná se o studijní text, který popisuje a vysvětluje danou problematiku. Kapitola, jako jediná část kurzu, může obsahovat další vnořenou úroveň, kterou můžou tvořit další kapitoly (podkapitoly), úkoly nebo testy.
- úkol - je cvičení, které student vypracovává dle instrukcí uvedených v úkolu. U každého úkolu má učitel možnost prohlížet odevzdané texty nebo soubory a udělovat hodnocení.
- test - jedná se o automaticky vyhodnocovaný test, složený z určitého počtu testových otázek. Učitel má možnost prohlížet a kontrolovat výsledky jednotlivých testů.
· na pravé straně se zobrazuje obsah jednotlivých částí kurzu. Obsah se liší podle typu vybrané části.

Poměr zobrazení levé a pravé části lze změnit najetím kurzoru myši na rozhranní mezi oběma částmi (kurzor myši se změní na vodorovnou dvojšipku) a stisknutím levého tlačítka myši a tažením upravíte velikost oken podle vlastních potřeb.

Strom kurzu

Strom kurzu popisuje obsah (složení) e-learningového kurzu. Jednotlivé kapitoly můžou obsahovat další podkapitoly, úkoly a testy. Tím vzniká stromová struktura, umožňující přehledně zobrazit celou osnovu kurzu. Kliknutím na název části kurzu ve stromu se v pravé části zobrazí obsah této části.

Rozbalování a sbalování částí stromu tlacitkarozbaleni

Pro větší přehlednost můžou být jednotlivé části (větve) stromu sbaleny. To zda některá kapitola obsahuje další části kurzu je ve stromu indikováno jednak ikonou kapitoly (kniha) a jednak ikonkou stromu (čtvereček se znaménkem plus nebo mínus).
Rozbalení příslušné větve stromu provedete kliknutím na ikonku čtverečku se znaménkem plus. Znaménko ve čtverečku se změní na mínus (indikuje rozbalenou větev) a ve stromu se zobrazí příslušné podkapitoly, případně úkoly a testy.
Obdobným způsobem provedete sbalení (skrytí) obsahu větve. Klikněte na ikonku čtverečku se znaménkem mínus - ikonka se změní na plus a obsah větve se skryje.

V případě, že potřebujete rychle sbalit nebo rozbalit celý strom, můžete použít tlačítka s odpovídajícími symboly na nástrojové liště nad stromem. Tlačítkem s plusem rozbalíte celý strom (včetně zanořených větví), tlačítkem s mínusem celý strom sbalíte, čili bude viditelná pouze 1. úroveň kapitol.

Obsah části kurzu

Obsah zvolené části kurzu je zobrazen v pravé části vedle stromu. Obsah různých částí má různý vzhled (obsahy jednotlivých částí budou popsány v následujících kapitolách), nicméně mají vždy stejné záhlaví.

V levé části záhlaví jsou dvě tlačítka, které umožňují zobrazit předchozí (<<) a následující (>>) část kurzu. Při procházení kurzu pomocí těchto tlačítek se vždy zobrazují všechny části tak, jak jdou za sebou bez ohledu na to, zda je příslušná větev ve stromu rozbalena či ne.
V prostřední části je uveden název aktuálně zobrazené části kurzu.
V pravé části je tlačítko s křížkem ( X ). Klinutím na toto tlačítko se ukončí práce s kurzem a zobrazí se seznam otevřených kurzů.


Nastavení kurzu

Některé vlastnosti otevřeného e-learningového kurzu může nastavovat vyučující, který kurz vede.

Po kliknutí na název kurzu ve stromu (první položka) se v pravé části zobrazí informace o otevřeném kurzu:
· Ikona - obrázek v levé části zobrazuje ikonu kurzu, kterou mu přiřadil autor. Ikona nelze změnit.
· Název kurzu - standardně má kurz název jaký mu zadal autor při jeho vytvoření, nicméně lze změnit např. tak, aby více vystihoval účel otevřeného kurzu. Tento název se bude zobrazovat u ikony otevřeného kurzu jak u učitelů tak i u studentů.
· Autor - zde je uvedeno plné jméno autora e-learningového kurzu. Slouží pouze pro informaci.
· Popis kurzu - umožňuje k otevřenému kurzu připojit poznámku, kterou chce vyučující sdělit studentům kurzu. Tento popis se zobrazuje u ikony kurzu pod názvem. Pokud je popis dlouhý, bude v ikoně zkrácen a doplněn třemi tečkami (...). Po najetí kurzorem myši na ikonu kurzu se v bublinové nápovědě zobrazí celý text popisu.
· Kurz otevřen - u každého kurzu lze definovat od kdy do kdy má být zpřístupněn pro studenty. Studenti, pro něž je kurz otevřen uvidí ikonu kurzu ihned, jak autor kurz otevře, ale pokud má kurz nastaveno, že dosud není zpřístupněn, uvidí student ve stromu pouze seznam hlavních kapitol, ale obsah jednotlivých částí bude nepřístupný.
Pokud není vyplněno datum do kdy je kurz otevřen, bude kurz přístupný do konce semestru (resp. pouze po dobu aktuálnosti předmětu, pro který byl otevřen). Pokud není vyplněn začátek kurzu, bude automaticky doplněno aktuální datum.
Pro zjednodušení zadávání datumu je možné využít kalendář, který se zobrazí po kliknutí na tlačítko "[=]" vedle editačního pole.

kalendar

Pod editačními poli pro zadání začátku a konce kurzu je informace o tom, pro kterou skupinu studentů (předmět, sem. skupina, téma) je kurz otevřen. V závorce je pak uveden počet studentů, kteří patří do této skupina, čili počet studentů, kteří mohou nebo musí kurz absolvovat.
· Nastavení - obsahuje zatrhávací pole pro povolení resp. nepovolení diskusního fóra pro tento otevřený kurz. Pokud je fórum povoleno, bude ve spodní části stromu zobrazen odkaz na diskusní fórum, ve kterém studenti mohou komunikovat s vedoucím kurzu (učitelem) nebo mezi sebou navzájem. Diskusní fórum je popsáno v kapitole Diskuse.
Diskusi je možné dočasně pozastavit (všechny příspěvky zůstanou zachovány) anebo zrušit kdykoliv během kurzu.

Po provedených změnách v nastavení kurzu je nutné kliknout na tlačítko "Uložit", aby se změny uložili. Pokud na toto tlačítko nekliknete, zůstanou nastaveny původní hodnoty.


Kapitoly

Po kliknutí na název kapitoly ve stromu se vpravo zobrazí obsah kapitoly.

Pokud autor kurzu podmínil přístup k této kapitole splněním jiné části kurzu (např. přečtením jiné kapitoly, splněním úkolu nebo testu) bude tato podmínka uvedena na začátku stránky.

U každé kapitoly je možné nastavit datum od kdy má být text kapitoly přístupný studentům. Toto omezení je možné využít v případě, kdy vyučující nechce aby studenti měli přístup k některým částem kurzu před určeným datem, např. aby část kurzu mohli studovat až po prázdninách.
Pro snadnější nastavení datumu je možní využít kalendář, který se zobrazí po kliknutí na tlačítko "[=]" vedle editačního pole.
Po změně datumu je nutné kliknout na tlačítko "Změnit" vpravo nahoře, aby se změněný údaj uložil.

poznamka Poznámka: Nastavení omezení u kapitoly se týká i všech částí, které obsahuje. To znamená, že pokud kapitola obsahuje nějaké podkapitoly, úkoly nebo testy, nebude mít student k těmto částem přístup před datem zadaným u nadřazené kapitoly. U jednotlivých podkapitol není toto datum potřeba nastavovat.


Úkoly

Úkoly jsou části e-learningového kurzu, ve kterých musí student vypracovat zadaný úkol a odevzdat ho buď ve formě textu, který napíše jako vypracování úkolu, nebo ve formě souboru, který připojí k danému úkolu. Vyhodnocení a oznámkování úkolů provádí vždy vyučující (vedoucí kurzu).

Každý úkol je rozdělen na dvě záložky:
· Zadání - kde je zobrazen text zadání úkolu a
· Hodnocení - zde se vyučujícímu zobrazuje seznam studentů, kteří úkol vypracovali a odevzdali, a kde může úkol hodnotit

Zadání úkolu

Na záložce "Zadání" je zobrazeno zadání úkolu tak, jak ho vidí i studenti.

Pokud autor kurzu podmínil přístup k tomuto úkolu splněním jiné části kurzu (např. přečtením jiné kapitoly, splněním úkolu nebo testu) bude tato podmínka uvedena v horní části záložky.

U úkolu je možné nastavit datum od kdy a do kdy má být úkol přístupný studentům. V této době studenti uvidí zadání a budou mít možnost odevzdávat vypracování úkolu. Vhodné je nastavit zejména datum DO, které v podstatě představuje nejzazší datum pro odevzdání úkolu. V případě, že datum DO není vyplněno, mají studenti možnost odevzdávat úkol během celého kurzu.
Pokud není některé z datumů nastaveno, uvažuje se příslušné datum (zahájení nebo konce) kurzu.

Pro snadnější nastavení datumů je možné využít kalendář, který se zobrazí po kliknutí na tlačítko "[=]" vedle editačního pole.

Po změně datumů je nutné kliknout na tlačítko "Změnit" vpravo nahoře, aby se upravené údaje uložili.

Hodnocení úkolu

Seznam studentů a hromadné hodnocení

Pokud žádný student doposud úkol neodevzdal, zobrazí se na záložce "Hodnocení" informativní text, že není odevzdán žádný úkol.
V opačném případě se zobrazí seznam studentů, kteří úkol odevzdali.

V seznamu je uvedeno příjmení a jméno studenta a datum, kdy byl úkol odevzdán. Seznam je řazen sestupně podle datumu odevzdání, což znamená, že poslední odevzdané úkoly jsou vždy na začátku seznamu. Dále může být v seznamu zobrazen sloupec pro zadávání známek a/nebo počtu bodů (záleží jaké hodnocení nastavil autor kurzu). Ke každému hodnocení je možné připojit poznámku - komentář k hodnocení. Tuto poznámku uvidí student jak v hodnocení úkolu, tak i v přehledu známek. Pokud bylo studentovi zapsáno hodnocení, bude místo rozbalovacího seznamu známek zobrazena udělená známka, místo textových polí pro zadávání počtu bodů a poznámky bude zobrazen udělený počet bodů a poznámka k hodnocení a v posledním sloupci seznamu bude uvedeno kdo a kdy hodnocení zapsal. V případě, že byl úkol hodnocen neúspěšně a student odevzdal opravený úkol znovu, má vyučující možnost zadat nové hodnocení.

V tomto seznamu je možné zapsat hodnocení (známky a/nebo body) více studentům najednou. Např. pokud si vyučující uloží odevzdané úkoly na svůj počítač, v klidu si práce přečte a ohodnotí a teprve potom chce známky zapsat do systému. Tento systém zápisu hodnocení je stejný jako zápis známek na záložce "Výuka" v informačním systému.
K zápisu známek je také možné využít známé rozhranní na záložce "Výuka". V seznamu hodnocení je nutné vybrat příslušný název hodnocení (je stejný jako název úkolu) v oddílu "Hodnocení kurzů". V seznamu studentů vpravo je možné, u těch studentů, kteří úkol odevzdali, zapsat známky stejně jako známky z předmětu.

Zápis známek na záložce "Výuka" je popsán v manuálu Internetové rozhranní.

Zobrazení odevzdaných úkolů

Pokud v seznamu studentů, kteří úkol odevzdali, kliknete na jméno studenta, zobrazený seznam se zmenší (zůstanou pouze první dva sloupce, aby bylo možné přepínat se mezi jednotlivými studenty) a vpravo od seznamu se zobrazí podrobné informace o studentovi, odevzdaném úkolu a hodnocení.

V horní části je uvedeno jméno a příjmení studenta a datum a čas odevzdání úkolu. Pod nimi jsou dvě záložky - pro prohlížení odevzdaných úkolů a pro zadávání známek. Kliknutím na tlačítko "Zpět na seznam" vpravo nahoře se zobrazí celý seznam s možností hromadného zápisu známek.

Na záložce "Vypracování" je k dispozici odevzdaný úkol studenta. Pokud byl součástí úkolu soubor (k úkolu může student připojit jeden soubor), zobrazí se tabulka s názvem souboru (jméno souboru je podle příjmení a jména studenta, přípona souboru zůstává zachována podle typu souboru, který student uložil), velikost souboru a datum uložení souboru na server.
Pokud má soubor příponu, kterou umí internetový prohlížeč zobrazit (např. obrázky typu .JPG, .PNG, .GIF, textové soubory .HTM, .TXT, ale i .DOC, .RTF, .PDF - pouze Internet Explorer), je možné kliknutím na název tento soubor přímo otevřít v novém okně prohlížeče. Pokud prohlížeč obsah souboru zobrazit neumí, nabídne ho k uložení na lokální disk.
Chcete-li soubor přímo uložit na lokální disk počítače, klikněte na obrázek ve sloupci "Uložit". Jako název souboru se nabídne příjmení a jméno studenta, přípona zůstane podle typu souboru. Tímto způsobem lze uložit všechny odevzdané úkoly do jednoho adresáře pro pozdější pročtení a ohodnocení.

Dále je na záložce "Vypracování" zobrazen text, který může student při odevzdávání úkolu vyplnit. Pokud byl odevzdán soubor, můžou být v tomto textu napsány poznámky k souboru nebo nemusí být text vyplněn vůbec. V případě, že úkol nebyl odevzdán ve formě souboru, bude text přímo obsahovat vypracování úkolu.
Pro pozdější hodnocení (nebo pro účely archivace apod.) je možné tento text uložit do textového souboru na lokální disk počítače. Uložení provedete kliknutím na odkaz "Uložit" vpravo dole pod textem. Internetový prohlížeč nabídne k uložení soubor s názvem podle jména a příjmení studenta a příponou .TXT. Tento soubor je možné otevřít v každém jednoduchém textovém editoru (např. Poznámkový blok v systému Windows).

Hodnocení odevzdaných úkolů

Na záložce "Známka" je možné odevzdaný úkol ohodnotit.

Pokud odevzdaný úkol doposud ohodnocen nebyl, bude možné vybrat z rozbalovacího seznamu známku a/nebo zadat počet bodů. To která možnost hodnocení bude k dispozici závisí na nastavení hodnocení úkolu autorem kurzu.
Dále je možné k hodnocení připojit poznámku, ve které by mělo být u nevyhovujících hodnocení zdůvodněno, proč bylo uděleno toto hodnocení. Po klinutí na tlačítko "Zapsat známku" se hodnocení uloží do systému a zobrazí se studentovi.
Jestliže je úkol hodnocen jako nevyhovující a maximální počet hodnocení (nastavuje autor kurzu) je menší než počet udělených hodnocení, má student možnost úkol opravit a odevzdat znovu. V tomto případě se nahradí odevzdaný soubor novým souborem, případně text vypracování se nahradí opraveným textem a vyučující může úkol znovu ohodnotit. Je-li počet udělených hodnocení roven maximálnímu počtu hodnocení, není možné poslední hodnocení změnit nebo udělit další hodnocení. Podle charakteru úkolu (jak ho nastaví autor) to může znamenat, že student kurz nemůže dokončit.

Jestliže byl úkol ohodnocen, bude místo rozbalovacího seznamu a editačních polí zobrazeno udělené hodnocení. V případě neúspěšného hodnocení je zobrazeno hodnocení až do doby, než student odevzdá opravený úkol. Poté bude možné zadat novou známku, přičemž všechna předchozí hodnocení jsou vypsána ve spodní části záložky "Známka".

upozorneni Upozornění: U každého studenta zůstává v kurzu vždy pouze poslední odevzdaný úkol. Pokud byl studentovi úkol vrácen k přepracování a student odevzdal opravenou verzi úkolu, bude v systému k dispozici pouze tato opravená verze. Jestliže učitel chce mít k dispozici všechny verze úkolu, které student odevzdal, musí si je průběžně ukládat na lokální disk počítače.


Testy

E-learningové testy se skládají z několika otázek, na které student odpovídá buď výběrem z nabízených možností nebo doplněním patřičného textu. Testy jsou vyhodnocovány automaticky ihned po odevzdání.

Každý test v otevřeném kurzu má dvě záložky:
· Informace - zde vyučující vidí vlastnosti testu tak, jak je nastavil autor, a zároveň může některé vlastnosti nastavit sám a
· Výsledky - kde jsou zobrazeny výsledky jednotlivých testů, které studenti odevzdali.

Informace o testu

Pokud autor kurzu podmínil přístup k tomuto testu splněním jiné části kurzu (např. přečtením jiné kapitoly, splněním úkolu nebo testu) bude tato podmínka uvedena v horní části záložky.

Na této záložce může vedoucí kurzu (učitel) nastavit od kdy do kdy je test přístupný studentům a tudíž od kdy do kdy můžou studenti test spouštět. Doporučujeme u jednotlivých testů nastavit oba tyto datumy, aby bylo časově omezeno spouštění testů. U testů, které nejsou součástí hodnocení kurzu (takzvaných "cvičných" testů), není nutné tyto datumy nastavovat - v tom případě bude test přístupný kdykoliv během kurzu a studenti si mohou test zkoušet průběžně.
Pokud není některé z datumů nastaveno, uvažuje se příslušné datum (zahájení nebo konce) kurzu.

Dále je možné nastavit, od kdy se mají studentům zobrazit opravené testy. V opraveném testu student uvidí, ve kterých otázkách udělal jakou chybu a jaká měla být správná odpověď. Aby bylo možné zabránit tomu, že student odevzdá neúspěšný test, podívá se, kde udělal chybu a následně spustí test znovu a zodpoví otázky správně, lze nastavit opožděné zobrazení opravených testů. Vyplněné datum musí být větší než konec zpřístupnění testu.
Pokud datum není vyplněno, bude možné zobrazit opravené testy ihned po odevzdání.

poznamka Poznámka: Výsledky testů se studenti dozví ihned po jeho odevzdání. Opravený test je test složený z těch otázek na které student odpovídal včetně vyplněných odpovědí a vyznačených správných a chybných odpovědí. Vyučující má přístup k opraveným testů ihned, jakmile je studenti odevzdají bez ohledu na nastavené datum.

Pro snadnější nastavení datumů je možné využít kalendář, který se zobrazí po kliknutí na tlačítko "[=]" vedle editačního pole.

Po změně datumů je nutné kliknout na tlačítko "Změnit" vpravo nahoře, aby se upravené údaje uložili.

Dále je na této záložce zobrazeno nastavení testu tak, jak ho nastavil autor kurzu. Tyto údaje mají pouze informativní charakter, to znamená, že vyučující nemá možnost tyto vlastnosti měnit. Je zde zobrazen čas, který mají studenti na vypracování testu, počet otázek, které test obsahuje, a počet spuštění testu, které udává, kolikrát student může test opětovně spustit (opravný test v případě nevyhovujícího hodnocení). Pokud je "Maximální počet spuštění testu" nastaven na např. 3, znamená to, že student má možnost dvou opravných testů.
Jestliže je test součástí hodnocení kurzu, bude na dalším řádku zobrazen minimální počet bodů, které musí student získat, aby mu byl test uznán za splněný. Pokud se jedná o cvičný test, bude zde zobrazena poznámka, že test není součástí hodnocení kurzu.
Na posledních třech řádcích jsou uvedeny počty bodů, které student získá za správnou, chybnou nebo nezodpovězenou otázku.

Výsledky testu

Pokud žádný ze studentů test doposud nespustil, bude na záložce "Výsledky" zobrazen text s informací, že nikdo test neřešil.
V opačném případě bude zobrazen seznam studentů, kteří test spustili včetně posledních výsledků.

V seznamu je uvedeno jméno a příjmení a datum a čas spuštění testu. Údaje v tabulce jsou řazeny sestupně podle datumu spuštění testu, tzn. že nejaktuálnější výsledky jsou na začátku seznamu.
V dalším sloupci je uveden čas poslední odpovědi. Pokud má student možnost test opakovat, bude ve sloupci "Pokus" je zobrazen počet spuštění testu. Ve sloupci "Hodnocení" je zobrazován průběžný počet bodů, které student v testu získal.
V posledním sloupci je odkaz, který umožní prohlédnou si vyhodnocený a opravený test. Prohlížení opravených testů bude popsáno dále.

V seznamu jsou zobrazovány průběžné údaje. To znamená, že v tabulce se zobrazí řádek v momentě, kdy student test spustí. Řádek testu, který student ještě stále vypracovává (doposud ho neukončil), je zobrazen šedou barvou. Údaje v tomto řádku nejsou konečné a mohou se měnit tak, jak student odpovídá na další otázky. Hodnoty ve sloupcích "Čas" a "Hodnocení" se tedy průběžně mění.
Počet bodů ve sloupci "Hodnocení", který je nižší než minimální počet bodů pro splnění testu, je zobrazen červenou barvou textu (označuje nesplněný test).

Pokud autor nastavil, že je test součástí hodnocení kurzu, vytvoří se automaticky vlastní hodnocení s názvem podle názvu testu. Hodnocení je učiteli přístupné na záložce "Výuka" u skupiny, pro kterou byl kurz otevřen. Hodnocení testu vidí i student v přehledu známek.
U cvičných testů se hodnocení nikam nezapisuje a lze ho zobrazit pouze v e-learningovém kurzu.

Zobrazení dosavadních výsledků studenta

Kliknutím na jméno studenta v seznamu se zobrazený seznam zmenší (zůstanou pouze první dva sloupce) a vpravo od seznamu se zobrazí výsledky všech spuštění testu od vybraného studenta.

Pro lepší přehlednost je nad přehledem výsledků uvedeno jméno a příjmení studenta.
Kliknutím na tlačítko "Zpět na seznam" napravo od jména studenta se zobrazí kompletní seznam s posledními výsledky.

Na záložce "Průběžné výsledky" je zobrazena tabulka se všemi spuštěnými testy. Testy jsou řazeny sestupně podle datumu spuštění (to znamená, že poslední spuštěný test je na začátku tabulky). Dále je zde uveden čas poslední odpovědi , hodnocení (dosažený počet bodů) a možnost zobrazit si libovolný opravený test. Seznam testů v této tabulce je stejně jako hlavní seznam průběžný, tzn. že se v něm zobrazují i průběžné výsledky testů, na kterých student ještě pracuje. Tyto testy jsou opět odlišeny šedou barvou textu, čímž je indikováno, že se odpovědi v testu ještě můžou změnit.

Zobrazení opraveného testu

Po kliknutí na odkaz "Zobrazit" ve sloupci "Opravený test" se otevře nové okno prohlížeče a v něm bude zobrazen vybraný test včetně odpovědí, které vybral student a včetně indikace správných a chybných odpovědí.

V záhlaví je uveden název testu a pod ním statistické údaje z testu. Ve spodní části je zobrazen obsah otázky s vyznačeno odpovědí, kterou uvedl student a s opravenými chybami v otázce. Pokud je odpověď správná, je u ní zelené zatržítko. Pokud je odpověď chybná, je označena červeným křížkem. U textových odpovědí je u chybných odpovědí uvedena správná odpověď v hranatých závorkách za červeným křížkem.
V odpovědi na obrázku student chybně uvedl počet 2 (správně mělo být 3), správně určil Irsko, dále mělo být zatrženo Dánsko (což student neudělal), naopak chybně zatrhl Itálii, a nezatrhl Velkou Británii, která měla být zatržena.

Jednotlivé otázky lze zobrazovat postupně pomocí tlačítek "<< předchozí" a "další >>" anebo je možné zobrazit přímo zvolenou otázku kliknutím na číslo uprostřed mezi těmito tlačítky. U jednotlivých čísel otázek je indikováno, zda je otázka zodpovězena správně (zelené zatržítko), chybně (červený křížek) nebo že otázka nebyla zodpovězena (bez označení - např. otázka č. 4).

Opravený test můžete zavřít ukončením okna prohlížeče (např. tlačítkem s křížkem X vpravo nahoře).


Diskuse

Diskusní fórum je volitelnou součástí otevřeného e-learningového kurzu. O tom, zda u konkrétního běhu kurzu bude k dispozici diskuse nebo ne rozhoduje vedoucí kurzu (učitel).

Pokud učitel diskusní fórum povolí, zobrazí se ve spodní části stromu kurzu odkaz na diskusi. Po kliknutí na tento odkaz se v pravé části zobrazí obsah diskuse - seznam témat.

V seznamu témat je uveden název tématu, autor (student nebo učitel), kolik příspěvků je v tématu a kdy byl vložen poslední příspěvek. Seznam je řazen sestupně podle datumu posledního příspěvku v tématu, čili poslední příspěvky jsou na začátku tabulky.

Témata, ve kterých přibyly některé příspěvky od posledního zobrazení diskuse, jsou označeny červeným slovem "nový", čímž upozorňují čtenáře, že si mají tato témata zobrazit a podívat se na nové příspěvky.

Založení nového tématu

První řádek tabulky je odkaz na vytvoření nového tématu. Pokud student nebo učitel chce diskusi rozšířit o nějakou problematiku, o níž se v diskusi doposud nemluvilo, vytvoří nové téma klinutím na tento odkaz.
U nového tématu je zapotřebí napsat název, pod kterým bude téma zobrazeno v seznamu. Z tohoto důvodu je vhodné název volit co nejvýstižněji k dané problematice. Kromě názvu musí autor tématu napsat první příspěvek. Pro psaní obsahu příspěvku může autor používat formátování textu, které mu nabízí jednoduchý editor příspěvků.
Pro uložení a zobrazení nového tématu diskuse je nutné kliknout na tlačítko "Vložit nový příspěvek" vpravo dole pod editorem příspěvků. Pokud si autor otevření nového tématu rozmyslel a nechce toto téma diskuse založit, může kliknout na tlačítko "Zpět na seznam témat", čímž se vrátí na předchozí seznam témat aniž by se nové téma vytvořilo.

Zobrazení příspěvků tématu

Klinutím na název tématu v seznamu se zobrazí obsah všech příspěvků.

Nahoře je uveden název zobrazeného tématu a tlačítko "Zpět na seznam témat" pro návrat k hlavnímu seznamu.
Dále následují jednotlivé příspěvky v tématu v tom pořadí, v jakém byly vloženy do tématu - to znamená, že první příspěvek je vždy nahoře. Každý příspěvek má v záhlaví zobrazeno své pořadové číslo (začínající #). Toto číslo je možné např. použít při odkazování se na některý z předchozích příspěvků, Např.: "jak již bylo uvedeno v #4" nebo "chci upozornit na příspěvek #7 v tématu Řešení úkolů" apod.
Za pořadovým číslem je uvedeno jméno autora příspěvku a pokud daný příspěvek přibyl od posledního zobrazení diskusního fóra, je za jménem zobrazen text "nový", který upozorňuje čtenáře na to, že tento příspěvek ještě nečetl.
V pravé části záhlaví je zobrazeno datum a čas vložení příspěvku.

Na konci obsahu tématu je jednoduchý editor, který umožňuje do tématu přidat nový příspěvek. V příspěvku je možné používat jednoduché formátování textu pro zvýraznění důležitých informací. Formátování textu je omezené, ale pro potřeby diskusního fóra postačuje. Aby se nový příspěvek uložil do tématu je potřeba kliknout na tlačítko "Vložit nový příspěvek" vpravo dole pod editorem.

Mazání příspěvků

Vedoucí kurzu (učitel) má jako jediný možnost diskusi řídit tím, že některé příspěvky může smazat. K tomu slouží odkaz v pravé části záhlaví.
K mazání příspěvků by mělo docházet výjimečně, např. pokud se v příspěvku zobrazí řešení nějakého úkolu, správné odpovědi testových otázek, sprostá slova a podobně.
Příspěvek se nesmaže úplně, protože by tím mohlo dojít k chybnému číslování příspěvků a k dezorientaci studentů, zejména autora, který by si mohl myslet, že se příspěvek neuložil. Při smazání se celý obsah příspěvku nahradí červeným textem "==== PŘÍSPĚVEK BYL SMAZÁN ====" a vlevo dole bude uvedeno plné jméno učitele, který příspěvek smazal a datum a čas, kdy ke smazání příspěvku došlo.


Studium kurzu

Studenti mají k e-learningovým kurzům přístup přes své webové rozhranní na záložce "E-learning".

Na této záložce jsou ikony jednotlivých kurzů, které byli pro studenta otevřeny v aktuálním semestru, případně ikony kurzů, které student absolvoval (nebo měl možnost absolvovat) v předchozích semestrech.
U každého kurzu je uveden obrázek (ikona, kterou kurzu přiřadil autor), název případně popis kurzu, které vyplňuje vedoucí kurzu (učitel). Pod obrázkem je uvedeno od kdy do kdy je kurz otevřen, tzn. lze ho studovat a plnit úkoly a testy, a pro kterou skupinu (předmět, seminární skupinu nebo téma) je kurz otevřen.

Klinutím na ikonu kurzu se zobrazí obsah e-learningového kurzu.

Obsah kurzu je rozdělen na dvě části:
· na levé straně je tzv. strom kurzu, který zobrazuje obsah kurzu. Celý e-learningový kurz se může skládat ze tří částí:
- kapitola - jedná se o studijní text, který popisuje a vysvětluje danou problematiku. Kapitola, jako jediná část kurzu, může obsahovat další vnořenou úroveň, kterou můžou tvořit další kapitoly (podkapitoly), úkoly nebo testy.
- úkol - je cvičení, které student vypracovává dle instrukcí uvedených v úkolu. Vypracovaný úkol lze odevzdat jako soubor nebo ve formě textu psaného přímo v úkolu. U odevzdaných úkolů je zobrazeno i hodnocení od učitele.
- test - ověřuje znalosti studenta z probrané problematiky. Testy jsou vyhodnocovány automaticky a některé (podle nastavení autora kurzu) lze spouštět i opakovaně. Student má možnost prohlížet výsledky jednotlivých testů.
· na pravé straně se zobrazuje obsah jednotlivých částí kurzu. Obsah se liší podle typu vybrané části.

Poměr zobrazení levé a pravé části lze změnit najetím kurzoru myši na rozhranní mezi oběma částmi (kurzor myši se změní na vodorovnou dvojšipku) a stisknutím levého tlačítka myši a tažením upravíte velikost oken podle vlastních potřeb.

Strom kurzu

Strom kurzu popisuje obsah (složení) e-learningového kurzu. Jednotlivé kapitoly můžou obsahovat další podkapitoly, úkoly a testy. Tím vzniká stromová struktura, umožňující přehledně zobrazit celou osnovu kurzu. Kliknutím na název části kurzu ve stromu se v pravé části zobrazí obsah této části.

Rozbalování a sbalování částí stromu tlacitkarozbaleni

Pro větší přehlednost můžou být jednotlivé části (větve) stromu sbaleny. To zda některá kapitola obsahuje další části kurzu je ve stromu indikováno jednak ikonou kapitoly (kniha) a jednak ikonkou stromu (čtvereček se znaménkem plus nebo mínus).
Rozbalení příslušné větve stromu provedete kliknutím na ikonku čtverečku se znaménkem plus. Znaménko ve čtverečku se změní na mínus (indikuje rozbalenou větev) a ve stromu se zobrazí příslušné podkapitoly, případně úkoly a testy.
Obdobným způsobem provedete sbalení (skrytí) obsahu větve. Klikněte na ikonku čtverečku se znaménkem mínus - ikonka se změní na plus a obsah větve se skryje.

V případě, že potřebujete rychle sbalit nebo rozbalit celý strom, můžete použít tlačítka s odpovídajícími symboly na nástrojové liště nad stromem. Tlačítkem s plusem rozbalíte celý strom (včetně zanořených větví), tlačítkem s mínusem celý strom sbalíte, čili bude viditelná pouze 1. úroveň kapitol.

Nepřístupné části kurzu

Přístup k některým částem kurzu (kapitolám, testům, úkolům) může být podmíněný splněním jiné části kurzu nebo datumem.
Splnění části kurzu se rozumí:
- u kapitol - první otevření kapitoly. Aby byla kapitola považována za splněnou (přečtenou) musí student alespoň jednou zobrazit obsah kapitoly (kliknutím na název kapitoly ve stromu).
- u úkolů - odevzdání úkolu a následné hodnocení vyučujícího klasifikačním stupněm nebo příslušným počtem bodů, představující vyhovující úkol. U nevyhovujících hodnocení může mít student možnost odevzdat opravený úkol znovu.
- u testů - odevzdání testu a jeho automatické vyhodnocení jako úspěšný test. V případě neúspěšného testu může mít student možnost test opakovat.
U některých částí kurzu může navíc vedoucí kurzu (vyučující) omezit přístup pouze v určitou dobu. Např. přístup k druhé polovině kurzu může být omezeno až od druhé poloviny semestru, aby se srovnaly rozdíly v rychlosti studia jednotlivých studentů.

Nepřístupná část kurzu je ve stromu kurzu indikována šedou barvou. Pokud tato část obsahuje další části (podkapitoly, úkoly nebo testy) není možné větev této části rozbalit, dokud nebudou splněny požadované podmínky. Kliknutím na název nepřístupné části se vpravo, kde se zobrazuje obsah jednotlivých částí, zobrazí informace o podmínkách, které je nutné splnit.

Obsah části kurzu

Obsah zvolené části kurzu je zobrazen v pravé části vedle stromu. Obsah různých částí má různý vzhled (obsahy jednotlivých částí budou popsány v následujících kapitolách), nicméně mají vždy stejné záhlaví.

V levé části záhlaví jsou dvě tlačítka, které umožňují zobrazit předchozí (<<) a následující (>>) část kurzu. Při procházení kurzu pomocí těchto tlačítek se vždy zobrazují všechny části tak, jak jdou za sebou bez ohledu na to, zda je příslušná větev ve stromu rozbalena či ne.
V prostřední části je uveden název aktuálně zobrazené části kurzu.
V pravé části je tlačítko s křížkem ( X ). Klinutím na toto tlačítko se ukončí práce s kurzem a zobrazí se seznam otevřených kurzů.


Nastavení kurzu

Po spuštění kurzu nebo po kliknutí na název kurzu ve stromu (první položka) se v pravé části zobrazí informace o kurzu.

Tyto údaje mají pouze informativní charakter. Patří mezi ně ikona (obrázek) kurzu, název a autor kurzu. Autor je člověk, který e-learningový kurz vytvořil a nemusí to být vždy vedoucí otevřeného kurzu (vyučující v kurzu). Vedoucím kurzu může být kterýkoliv učitel z předmětu, příp. seminární skupiny, pro kterou je kurz otevřen.
Dále může být uveden popis kurzu, který nějakým způsobem upřesňuje obsah kurzu. Na posledním řádku je uvedeno, od kdy do kdy je kurz otevřen pro studenty, tzn. v jakém období je možné kurz studovat.

upozorneni Upozornění: pokud kurz doposud nezačal, bude ve stromu zobrazena pouze první úroveň obsahu kurzu (hlavní kapitoly) a všechny části kurzu budou nepřístupné!


Kapitoly

Kliknutím na název kapitoly ve stromu kurzu se v pravé části zobrazí obsah (učební text) zvolené kapitoly. Učební texty kapitol jsou dílem autora kurzu a nejsou součástí informačního systému ISvoš.

V kapitolách může být použito "zvýraznění" částí textu, které jsou z nějakého hlediska významné. Grafické pojetí zvýraznění závisí na použitém vzhledu kurzu a může být u každého kurzu jiné. Toto zvýraznění má studenta upozornit na např. důležitou část textu nebo naopak rozšiřující text, který je určen pouze pro zájemce o danou problematiku. Každé zvýraznění má svou ikonku (obrázek), které určuje význam zvýrazněného textu.

V případě, že kapitola není přístupná, zobrazí se upozornění a podmínky za kterých bude kapitola přístupná.


Úkoly

Úkoly jsou části e-learningového kurzu, ve kterých student vypracuje zadaný úkol a odevzdá ho buď ve formě textu, který napíše jako vypracování úkolu, nebo ve formě souboru, který připojí k danému úkolu. Vyhodnocení a oznámkování úkolů provádí vždy vyučující (vedoucí kurzu).

Každý úkol je rozdělen na tři záložky:
· Zadání - kde je zobrazen text zadání úkolu,
· Vypracování - umožňuje studentovi odevzdat vypracovaný úkol a
· Hodnocení - zde se zobrazuje hodnocení odevzdaného úkolu vyučujícím.

Zobrazení zadání úkolu

Na záložce "Zadání" je zobrazeno zadání úkolu. Podle pokynů v zadání je nutné vypracovat daný úkol a odevzdat ho vyučujícímu k ohodnocení. Pokud je vypracování úkolu omezeno do nějakého data, bude toto datum uvedeno nad zadáním úkolu. Mimo uvedené datumy nelze úkol odevzdávat.

Odevzdání vypracování úkolu

Vypracovaný úkol se odevzdává na záložce nazvané "Vypracování".
U každého úkolu jsou dvě možnosti odevzdání. Buď je možné text vypracování úkolu napsat přímo do textového pole v horní části záložky (je vhodné pro jednodušší vypracování úkolu) anebo lze vypracování odevzdat ve formě souboru, který bude připojen k úkolu. V druhém případě je možné horní textové pole využít pro napsání doprovodného nebo doplňkového textu k připojenému souboru (pokud v zadání není uvedeno jinak).

Připojený soubor

V oddíle "Připojený soubor" jsou uvedeny informace o nahraném souboru. Pokud žádný soubor dosud nahrán nebyl, je zde uveden nápis "NENÍ PŘIPOJEN ŽÁDNÝ SOUBOR". Kromě jména souboru, které je shodné s názvem souboru (přípona, rozlišující typ souboru, zůstává zachována) je zde uvedena velikost souboru (v násobcích bytů) a datum nahrání souboru na server.
Kliknutím na obrázek ve sloupci "Ulož" je možné nahraný soubor uložit na lokální disk počítače a kliknutím na obrázek "Smazat" v posledním sloupci dojde k odstranění souboru ze serveru.
Pokud chcete připojit nový soubor nebo změnit stávající odevzdaný soubor, vyplňte název souboru a cestu k němu do textového pole "Přidat soubor", resp. "Změnit soubor". Pro zjednodušení zadání cesty a názvu souboru můžete kliknout na tlačítko "Procházet ..." a v otevřeném dialogovém okně procházením adresářové struktury na vašem disku najít požadovaný soubor. Klinutím na tlačítko "Nahrát" se zadaný soubor uloží na server.

tip Tip: V případě, že je potřeba odevzdat více souborů k jednomu úkolu, je možné tyto soubory spojit do jednoho pomocí archivačních programů (např. ZIP, RAR apod.)

Maximální velikost odevzdávaného souboru je 2 MB. Větší soubory nebudou na server uloženy na což bude student upozorněn chybovou hláškou. U odevzdávaných souborů nejsou povoleny přípony serverových skriptů (např. .PHP, .PHP3, .PHTML, .INC apod.)

Odevzdání úkolu

Pokud vyplňujete vypracování úkolu přímo do textového pole v horní části záložky a potřebujete práci přerušit, ale úkol ještě nechcete odevzdat, klikněte na tlačítko "Uložit, ale zatím neodevzdávat". Tím se napsaný text uloží k otázce a při příštím přihlášení na něm budete moci dále pracovat. Připojený soubor je uložen jako součást odpovědi ihned po jeho nahrání na server, čili po nahrání souboru není nutné klikat na toto tlačítko.

Jestliže je vypracování úkolu kompletní, klikněte na tlačítko "Odevzdat úkol". Po kliknutí na toto tlačítko se celá záložka uzamkne, aby nebylo možné dodatečně vypracování úkolu měnit. Je možné pouze číst vypracovanou odpověď případně uložit odevzdaný soubor na disk lokálního počítače.

V případě, že vyučující ohodnotí odevzdané vypracování úkolu jako nevyhovující, bude možné opět vypracování úkolu měnit a opravenou verzi odevzdat znovu.

Hodnocení úkolu

Na záložce "Hodnocení" je uveden stav odevzdaného úkolu a hodnocení vyučujícím.

Stav úkolu je uveden v prvním řádku a může mít 4 varianty:
1. úkol není odevzdán - vypracování úkolu nebylo doposud odevzdáno
2. úkol čeká na hodnocení - vypracování úkolu bylo odevzdáno, ale vyučující doposud úkol neohodnotil
3. úkol nesplněn - vyučující hodnotil úkol jak nevyhovující. Pokud má student možnost dalšího hodnocení, může vypracování opravit a odevzdat znovu
4. úkol splněn - vyučující ohodnotil úkol jako vyhovující - student má úkol splněný a může pokračovat ve studiu kurzu.
Pro jednodušší orientaci a přehlednost je pozadí pod textem stavu vybarveno. Barva pozadí závisí na variantě stavu.

Pokud byl úkol odevzdán, je pod stavem uvedeno datum a čas odevzdání vypracování úkolu. Vpravo od datumu odevzdání je uveden maximální počet hodnocení, což počet, kolikrát je možné úkol odevzdat. Pokud byl úkol hodnocen jako nevyhovující a počet udělených hodnocení je stejný jako max. počet hodnocení, nemá student již další možnost odevzdat opravené vypracování úkolu a tudíž nemá úkol splněn.

Dále je na této záložce zobrazeno hodnocení udělené vyučujícím. Hodnocení může být buď známkou z klasifikační stupnice nebo počtem bodů anebo kombinací obojího. V poznámce může být uveden slovní komentář učitele k odevzdanému vypracování (výčet chyb, nepřesností apod.). V posledním řádku je uvedeno kdo a kdy hodnocení zapsal do informačního systému.

Ve spodní části záložky může být zobrazen přehled předchozích hodnocení, u kterých je uvedeno hodnocení (známka a/nebo počet bodů, poznámka a kdo a kdy hodnocení zapsal.

poznamka Poznámka: hodnocení úkolů je i součástí hodnocení předmětu a tudíž se toto hodnocení zobrazuje i v přehledu známek na záložce "Přehled studia" u předmětu, pro který byl kurz otevřen.


Testy

Testy jsou části e-learningového kurzu, které jsou složeny z předem daného počtu otázek, ve kterých se vybírá nebo vyplňuje správná odpověď. Testy jsou vyhodnocovány automaticky a tudíž se výsledek zobrazuje ihned po odevzdání testu.

Po kliknutí na název testu ve stromu kurzu se v pravé části zobrazí informace o vybraném testu.

Mezi tyto informace patří zejména čas na vypracování testu, počet otázek a maximální počet spuštění, což je počet, kolikrát lze test opakovat. Pokud student vyčerpá všechny pokusy, nedovolí mu systém test již znovu spustit.

Dále jsou zde zobrazeny podmínky hodnocení. Hodnocení testu může být součástí hodnocení kurzu, v tom případě bude v řádku "Hondnocení" uveden minimální počet bodů, které musí student získat, aby měl test splněný. Pokud test není zahrnutý do hodnocení kurzu (tzv. cvičný test), je v tomto řádku uvedeno, že hodnocení testu není součástí hodnocení kurzu. V tomto případě výsledek testu nemá vliv na pokračování ve studiu kurzu.
Pod hodnocením je pro informaci uvedeno, kolik bodů je za správnou odpověď, špatnou odpověď a nezodpovězenou otázku.

V prostřední části je odkaz, kterým lze spustit test a pod ním je informace o tom, kolikrát je ještě možné test spustit. Pokud již byly vyčerpány všechny pokusy, bude zde napsáno "TEST NELZE SPUSTIT".

Ve spodní části je zobrazena tabulka s dosaženými výsledky testu. V tabulce je uvedeno pořadové číslo spuštění testu, datum a čas spuštění testu a čas poslední odpovědi. Údaje v tabulce jsou seřazeny sestupně podle spuštění testu, to znamená, že poslední spuštěný test je vždy na začátku tabulky. Dále je v tabulce uvedeno hodnocení, čili počet získaných bodů. V posledním sloupci je odkaz "Zobrazit", který v novém okně prohlížeče zobrazí vybraný test včetně doplněných odpovědí a vyznačených správných či chybných odpovědí.
Vyučující (vedoucí kurzu) může nastavit, že zobrazování opravených testů bude možné až po určeném datu. Toto může být např. z důvodu zabránění opisování správných odpovědí od studentů, kteří již test odevzdali. V tom případě bude odkaz na zobrazení opraveného testu neaktivní a v horním řádku tabulky bude uvedeno, od kdy budou opravené testy přístupné.

Spuštění testu

Klinutím na odkaz "Spustit test" uprostřed stánky se v okně prohlížeče zobrazí první otázka testu

V záhlaví je vlevo uveden název spuštěného testu a vpravo zbývající čas do konce testu. Čas se automaticky odečítá a po uplynutí vyhrazeného času se test ukončí, přičemž změna v odpovědi poslední otázky se ignoruje.
Jednotlivé otázky je možné zobrazovat buď postupně, pomocí tlačítek "<< předchozí" a "další >>", anebo je možné zobrazit přímo zvolenou otázku kliknutím na číslo otázky uprostřed mezi tlačítky "<< předchozí" a "další >>". Čísla nezodpovězených otázek jsou psána tučně, čísla otázek, na které již bylo odpovězeno, jsou psány normálním písmem. Odpovědi na jednotlivé otázky jsou ukládány průběžně, což znamená, že kdyby nebylo možné test dokončit (např. reset počítače, přerušení připojení k Internetu) budou zaznamenány alespoň některé odpovědi s časem poslední odpovědi. Zobrazovat lze opětovně i otázky na které již bylo odpovězeno. V tom případě bude v otázce vyznačena uvedená odpověď. Takto lze vyplněnou odpověď zkontrolovat a případně i opravit. Při přechodu na jinou otázku nebo při ukončení testu se odpověď uloží (pokud neuplynul vyhrazený čas).

Prostřední a největší část okna zabírá text vlastní otázky s možnostmi odpovědí. Test umožňuje otázky, v nichž z nabízených odpovědí může být jedna, více nebo žádná správná anebo je nutné správnou odpověď doplnit do patřičného textového pole (nebo více polí).

Pod zněním otázky je uprostřed tlačítko "Ukončit test". Kliknutím na toto tlačítko se zobrazí potvrzovací dialog s otázkou, zda chcete opravdu tento test ukončit. Pokud kliknete na tlačítko "Storno", vrátíte se zpět k zobrazené otázce testu a můžete některé odpovědi zkontrolovat, opravit nebo doplnit. Pokud kliknete na tlačítko "OK", zobrazí se stránka s informacemi o právě ukončeném testu e-learningového kurzu a v oddílu "Výsledky" přibude na začátku tabulky nový řádek s vyhodnocením ukončeného testu.

Zobrazení opraveného testu

Po kliknutí na odkaz "Zobrazit" ve sloupci "Opravený test" se otevře nové okno prohlížeče a v něm bude zobrazen vybraný test včetně uvedených odpovědí a indikace správných a chybných odpovědí.

V záhlaví je uveden název testu a pod ním statistické údaje z testu. Ve spodní části je zobrazen obsah otázky s vyznačeno odpovědí, kterou uvedl student a s opravenými chybami v otázce. Pokud je odpověď správná, je u ní zelené zatržítko. Pokud je odpověď chybná, je označena červeným křížkem. U textových odpovědí je u chybných odpovědí uvedena správná odpověď v hranatých závorkách za červeným křížkem.
V odpovědi na obrázku student chybně uvedl počet 2 (správně mělo být 3), správně určil Irsko, dále mělo být zatrženo Dánsko (což student neudělal), naopak chybně zatrhl Itálii, a nezatrhl Velkou Británii, která měla být zatržena.

Jednotlivé otázky lze zobrazovat postupně pomocí tlačítek "<< předchozí" a "další >>" anebo je možné zobrazit přímo zvolenou otázku kliknutím na číslo uprostřed mezi těmito tlačítky. U jednotlivých čísel otázek je indikováno, zda je otázka zodpovězena správně (zelené zatržítko), chybně (červený křížek) nebo že otázka nebyla zodpovězena (bez označení - např. otázka č. 4).

Opravený test můžete zavřít ukončením okna prohlížeče (např. tlačítkem s křížkem X vpravo nahoře).


Diskuse

Diskusní fórum je volitelnou součástí otevřeného e-learningového kurzu. O tom, zda u konkrétního běhu kurzu bude k dispozici diskuse nebo ne rozhoduje vedoucí kurzu (učitel).

Pokud učitel diskusní fórum povolí, je zobrazen ve spodní části stromu kurzu odkaz na diskusi. Po kliknutí na tento odkaz se v pravé části zobrazí obsah diskuse - seznam témat.

V seznamu témat je uveden název tématu, autor (student nebo učitel), kolik příspěvků je v tématu a kdy byl vložen poslední příspěvek. Seznam je řazen sestupně podle datumu posledního příspěvku v tématu, čili poslední příspěvky jsou na začátku tabulky.

Témata, ve kterých přibyly některé příspěvky od posledního zobrazení diskuse, jsou označeny červeným slovem "nový", čímž upozorňují čtenáře, že si mají tato témata zobrazit a podívat se na nové příspěvky.

Založení nového tématu

První řádek tabulky je odkaz na vytvoření nového tématu. Pokud student nebo učitel chce diskusi rozšířit o nějakou problematiku, o níž se v diskusi doposud nemluvilo, vytvoří nové téma klinutím na tento odkaz.
U nového tématu je zapotřebí napsat název, pod kterým bude téma zobrazeno v seznamu. Z tohoto důvodu je vhodné název volit co nejvýstižněji k dané problematice. Kromě názvu musí autor tématu napsat první příspěvek. Pro psaní obsahu příspěvku může autor používat formátování textu, které mu nabízí jednoduchý editor příspěvků.
Pro uložení a zobrazení nového tématu diskuse je nutné kliknout na tlačítko "Vložit nový příspěvek" vpravo dole pod editorem příspěvků. Pokud si autor otevření nového tématu rozmyslel a nechce toto téma diskuse založit, může kliknout na tlačítko "Zpět na seznam témat", čímž se vrátí na předchozí seznam témat aniž by se nové téma vytvořilo.

Zobrazení příspěvků tématu

Klinutím na název tématu v seznamu se zobrazí obsah všech příspěvků.

Nahoře je uveden název zobrazeného tématu a tlačítko "Zpět na seznam témat" pro návrat k hlavnímu seznamu.
Dále následují jednotlivé příspěvky v tématu v tom pořadí, v jakém byly vloženy do tématu - to znamená, že první příspěvek je vždy nahoře. Každý příspěvek má v záhlaví zobrazeno své pořadové číslo (začínající #). Toto číslo je možné např. použít při odkazování se na některý z předchozích příspěvků, Např.: "jak již bylo uvedeno v #4" nebo "chci upozornit na příspěvek #7 v tématu Řešení úkolů" apod.
Za pořadovým číslem je uvedeno jméno autora příspěvku a pokud daný příspěvek přibyl od posledního zobrazení diskusního fóra, je za jménem zobrazen text "nový", který upozorňuje čtenáře na to, že tento příspěvek ještě nečetl.
V pravé části záhlaví je zobrazeno datum a čas vložení příspěvku.

Vedoucí kurzu (učitel) má jako jediný možnost diskusi řídit tím, že některé příspěvky může smazat. Příspěvek se nesmaže úplně, protože by tím mohlo dojít k chybnému číslování příspěvků a k dezorientaci studentů, zejména autora příspěvku, který by si mohl myslet, že se příspěvek neuložil. Při smazání se celý obsah příspěvku nahradí červeným textem "==== PŘÍSPĚVEK BYL SMAZÁN ====" a vlevo dole bude uvedeno plné jméno učitele, který příspěvek smazal a datum a čas, kdy ke smazání příspěvku došlo.

Na konci obsahu tématu je jednoduchý editor, který umožňuje do tématu přidat nový příspěvek. V příspěvku je možné používat jednoduché formátování textu pro zvýraznění důležitých informací. Formátování textu je omezené, ale pro potřeby diskusního fóra postačuje. Aby se nový příspěvek uložil do tématu je potřeba kliknout na tlačítko "Vložit nový příspěvek" vpravo dole pod editorem.